3

My friend and I decided to try making our own 1.7.9 server but we ran into some problem with ports.

I followed this guide and did a bit more research and I was able to connect to my server, but my friend couldn't get his server with his despite using the same method as I did.

First, I got my IPv4 address: ipv4

Then I set my ports: nat1

port1

Then I allowed the port in my firewall's advanced settings: firewall

Then I used canyouseeme.org to check if the port is open. check

DMZ is set to my internal IPv4 address (we changed it to his when we try to get his server up)

At first mine did not work, but after reseting the modem and giving it 5 minutes or so, I was able to get on with my public ip obtained from ipchicken.com

I tried getting my friend to follow the same step but idk why it doesnt work for him.. anyone know what could have possibly gone wrong?

We are both connected to the same modem. I used port 25565 and he used 2224, a port that is not used by anything. He even turned his firewall off. canyouseeme.org stated that his port is open but when we try to connect to the server, we keep getting the connection refused message. I tried getting him to use 25565 as well (modified the NAT rule changing my internal ip to his)

  • By chance, are you saying that your friend is building their own server with these same steps,or that they're only trying to connect to your server? -- everything on your side looks correct, they wouldn't need to do the same for outbound. – NBN-Alex Jul 4 '16 at 7:33
2

Your problem here has nothing to do with the ports you are using. You did follow all of the correct steps involved with setting up your ports on your router/modem and your firewall.

Your problem is that you gave your friend your local IP, not your public IP.

You see, your device (in this case your computer) is connected to your router, which sets up a local connection. When multiple devices are connected to the router this is called a LAN, or Local Area Network. Each device connected to the network will have a unique IP, for example:

Device 1 will be: 192.168.1.1

Device 2 will be: 192.168.1.2

Device 3 will be: 192.168.1.3

And so on and so forth.

But this does not allow your friend to connect to your computer. Unless they are on the same network as you, their machine will have no way of finding yours. What you are looking for is your public IP.

It is very easy to find, simply go to google.com and search 'what is my ip' like so:Google.com

After your ports are all set up, have your friend connect to the IP show by google (mine is asterisked out). This should solve your problem.

EDIT: Having been told that this is not the problem, I have an edit. This problem is not caused by issues with ports or your router/modem. This problem is caused by what is called FEEDBACK, or network feedback. Network feedback happens when a signal coming from inside a routers system is directed out of thw router, and then right back into it. Since the server is local to your computer, you ought ti be able to use your local IP adress. However, your friend wont be able ro connect with your public IP adress, due to network feedback.

I have actually had this problem before, so this ought to be an easy fix. If your friend is on the same network as yourself, you should just use the LAN function on your minecraft. If not, there is no reason connecting to your public ip from another loc action shouldn't work. Ill try and find some references asap, but I hope this solves your problem.

  • actually i did. He gave me his public ip and it still doesnt work, which is why i am asking this question everywhere lol – user77712 Jun 1 '14 at 5:33
  • Sorry about the wait. Ill update my answer, now that I have a better understanding of what is wrong. This has actually happened to me, so I know how to fix it – Despato Jun 11 '14 at 2:49
0

I don't like to mess with port forwarding in my router when there's an easier way. Instead I use ngrok to allow people outside my network to connect to my MC server. Works on Windows, Mac and Linux and only allows traffic through while ngrok is running.

If you want to try, it's pretty easy to set up.

Go here: https://ngrok.com/download

Download.

Sign up.

Go here and copy the command it shows (if you're signed in): https://dashboard.ngrok.com/auth (on Windows you don't need the ./ at the beginning)

In a terminal window (command prompt in Windows), run that command in the same directory as the ngrok executable you downloaded.

Then in that directory use the command "ngrok tcp 25565"

This will show a few things in the terminal, but you're looking for where it says: tcp://0.tcp.ngrok.io:#####, where the # characters are numbers. Give this to your friend and they should be able to connect.

The only down side is that each time you start ngrok, the last 5 numbers change, so you have to send them to your friend when you start ngrok.

You can also save the "ngrok tcp 25565" to a .bat file. Say you put ngrok.exe in the C:\ drive. Then your bat file would have this command (with the quotes):

"C:\ngrok" tcp 25565

Or you can just leave the bat file in the same directory as ngrok and place a shortcut on your desktop or wherever you want to have it.

-1

Because Minecraft is based on the port 25565. if you look it up, all minecraft servers are hosted on port 25565. minecraft MUST be port 25565, no matter what. PERIOD.

  • Could you be a bit more informative? Simply stating 'it has to do this, no exception' is not as helpful as providing insight on why. – user106385 Jul 3 '16 at 5:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.