I have played a couple of games using the online games options in Watch Dogs, however today whenever I try to join a game I get the error "Unable to connect to public sessions. Please check your NAT type" as follows;

enter image description here

My current network configuration is with me behind a router with UPnP enabled but for diagnostic purposes I have tested this both with my PC in the DMZ with no firewall enabled and using PPPOA with no firewall enabled so this doesn't seem to be an issue on my end.

Since this was working and no settings have changed on my end, what could be the cause of this error? Are there any suggested settings that I should apply to resolve this problem?

  • Check ports on your router, you may need to unblock and forward a few – eyeofthehawks May 31 '14 at 22:53
  • I contacted Ubisoft about this today. They said that a LOT of people were reporting this issue on launch day and it was "fixed" after some minor tweaking of their servers. Apparently that tweaking fixed this for the masses and left us an unfortunate minority. They suggested the problem is their server and it may get fixed with an upcoming patch. – leigero Jun 1 '14 at 1:29
  • Please edit the questions to tell us if this is the PC/PS4/XboxOne version. I had this exact same error on PS4 for two days, then Ubisoft did something on their end to fix it. It was working fine since launch, then blackout for 2 days, then fixed again - I did nothing on my end to attempt to fix it. – sergserg Jun 1 '14 at 16:28
  • Do you still have the problem? I had it once on PS4, and some google results advised to just restart the game and it has worked for me ever since. – Kodama Jun 3 '14 at 19:02

I disabled every network adapter I had installed except for the one required for internet access.

I had VMWare Workstation installed, the adapters of which seemed to be the culprit.

I don't recommend forwarding ports unless you're aware of the security implementations of doing such (especially :80 and :443).

  • Thanks, that was it for me too. No need to forward ports. I had the same problem with the latest Splinter Cell, seems to be a recurring thing with Ubisoft / Uplay games. – Xeon06 Jun 1 '14 at 20:05
  • This fixed it for me as well, although I only had VMWare Player installed, not the full blown workstation. – Meorrow Jun 3 '14 at 4:09
  • +1 for "especially :80 and :443". That is such absolutely terrible advice I've deleted it from the other answer (if you can't make outbound connections on port 80, you'll have much bigger problems than just not being able to play a video game...) – BlueRaja - Danny Pflughoeft Jun 3 '14 at 22:43

I found one solution that worked for me.

In the GameProfile.xml file I changed EnableNatTraversal from "1" to "0". On Windows 7 the configuration file can be found at Documents\My Games\Watch_Dogs{SOME_ID}\GameProfile.xml On other Windows versions it is probably located somewhere in you "My Documents" folder.

SOME_ID is just a folder with a GUID like name. (If you have multiple folders, try to look in all of them)

  • 1
    This does work. Haven't been able to play online since buying the game on PC. One change of EnableNatTraversal from 1 to 0 and it now works. – user77963 Jun 3 '14 at 20:29
  • I have heard this fixes the issue for people who have public IPs assigned directly to their computers and are not using NAT – Mark Henderson Jun 3 '14 at 22:49

I had the same problem. I solved it by forwarding the ports as stated on the official Ubisoft support page.

For the actual game:

UDP: 9000, 9103, 11000, 11001, 11002, 11005

For Uplay: (These have to be open for outbound traffic only.)

TCP: 13000, 14000, 14008

  • Don't open all those ports at once. Try the UDP ones first, add one after the other. As usual (unfortunately), support people are just lazy and list all ports, no matter whether they're indeed incoming or outgoing. Opening up TCP ports 80 and 443 is most likely not needed, but might make your computer vulnerable to malware trying to run a server for communication purposes on your PC. – Mario Jun 1 '14 at 11:38
  • 2
    I doubt opening ports will make a difference if running in a DMZ didn't. – kotekzot Jun 1 '14 at 19:15

Not the answer you're looking for? Browse other questions tagged or ask your own question.