0

I went and brought i think all story based DLC for Mass Effect 3 (Leviathan, Omega, Citadel Part 1 & 2 and From Ashes) and i had already downloaded the Extended DLC which expands the ending.

After waiting for about an hour for Leviathan to download i decided to let the rest download in the background as i played the game, i did this with the Extended Ending DLC.

It took the rest of the night (from 7PM - 11:30PM) to download everything else, knowing that the DLC won't be working until i restarted the game i quit back to the x-box 360 dashboard and started the game back up, when i went into the menu 3 messages appeared

"Checking Downloadable Content" -> "Checking Save Data" -> "Checking Downloadable Content"

figuring it was because i had just downloaded about 6GB i thought id's wait, however after approx 1/2 an hour it was still sitting on the 3rd message, all i could do was attempt to connect to EA which i wasn't going to do as 1) i didn't have an account and 2) i saw no reason to since Leviathan worked fine (i could see the new mission in my journal).

I had to shut the system down, the next morning i checked the data on my harddrive and saw an file about the title cache and it being incomplete, i deleted this and all the new DLC and the game worked fine (the 3rd message only appears for less than a second), i re downloaded all the DLC this time via the X-Box like i did with Leviathan and wait till it was all done.

starting the game up again it did the same thing (3rd message remained), this time i waited 2 hours (10AM -> 12PM, 10AM was when i started watching Maria Watches Over Us and after that was finished i played Etrain Odyssey until it was lunch time at 12) and on occasion turning my controller back on, the 3rd message still remained.

I read that there was a problem with the Citadel DLC so i deleted the DLC again and re-downloaded just From Ashes being the smallest, at first it worked and i could access the menu again (3rd message was around for a second) however i wanted to make sure it would still work after i returned to the dashboard and went back into the game. when i did this the problem returned, i did the exact same with Omega, same problem as From Ashes (at first could access the menu but after restarting the game the 3rd message remained)

I have a Physical Copy of Mass Effect 3 (Omniblade Edition) and i installed both disks to cut down on load times, how can i get the DLC i spent $50 to work?

  • Have you tryed clearing your systems cache? This is a very odd ,and I am sure, vexing problem. It sounds like an issue with your xbox? Try looking up how to clear out the cache. (Going to the system tab then holding a few buttons) if that doesnt solve the issue. Going to have to try xbox support. (Then hope that they can help. Because EA has notoriously bad support. That usually just blames you or your hardware.) Best of luck. – Bob Jun 2 '14 at 3:28
  • I am shocked it worked because ME3 and ME2 both always required an account in the past. I would try connecting an account see if that helps. – Ramhound Jun 2 '14 at 13:12
-1

My experience with the games have been on the PC, but, you need an EA/Origins account confirmably from first hand experience, on PC, to properly download and use DLC since it is authenticated through the Cerberus Network equivalent. I think you should, if the above answer wasn't the solution, getting an EA Account. I forget if it allows you to link it to Xbox or Playstation accounts, but I seem to remember that being the case for Dead Space 2.

  • You do not need an origin account for DLC over xbox, atleast. – user106385 Sep 26 '15 at 12:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.