2

I have a Nvidia Gtx 770 MSI twin Frozr 2gb version and I have used Auto Detect in Watch Dogs but for some reason I get MASSIVE Fps drops when moving around the world. Like it comes to a complete halt sometimes. It is worse when it's driving. I tried turning down the setting all to medium and it still didn't fix the issue.

  • I've noticed that on some missions, the FPS would drop significantly while playing for extended periods. I've found that restarting the game often helps. – Aceofgods Jun 10 '14 at 7:23
  • A patch to help with the PC's lack of a unified memory system is supposedly coming. A quick google search should link you to either summary articles or the twitter posts about it but until it comes out all we can do is speculate they are doing Something. – James Jun 10 '14 at 9:43
  • Probably obvious, but make sure you are using the latest drivers for your graphics card. – Fredrik Jun 10 '14 at 10:34
  • How much memory. The game can utilize more then 3GB of memory. I have a 770 and experience none of the issues you describe, except in certain cases, where there was a huge transistion in something but even then the game was asbsultely playable. You can always turned the graphics down, but I was able to play on extreme highest settings without a problem with the 770 and the current drivers. Be sure you have install all updates to the game the day 1 update fixed some of the problems. – Ramhound Jun 10 '14 at 16:19
  • To be fair, a lot of the problem is probably coming from Nvidia's drivers. Not even my Titan Blacks in SLI is immune to this problem. Even dropping all settings to low does nothing for me. AC4 multiplayer suffered a lot on release if you ran SLI. Stupid glitches. You'd have to turn off SLI to have everything look normal. Took 3 months for Nvidia to finally release drivers that fix that. The problems we're seeing here doesn't surprise me one bit. – Jeff Mercado Jul 11 '14 at 2:05
1

Since Watch Dogs is a poorly PC Port, there are no fixes for the issues you currently face. But since youre using an NVidia, you can download GEforce Experience and choose the Watch Dogs Profile, which will automatically set everything to optimized settings for the game. It wont remove all the issues, but it might make it more palyable.

  • I've optimized the game using the Experience app and it is still really awful. I was doing just driving from one side mission to next and the game would freeze up for like 7 seconds then slowly pick up speed then slowdown again. – Drmixable Jun 12 '14 at 3:49
0

I have the same issue with frame-drops with a GTX 760. I wasn't able to fix the issue, but I did alliviate it a lot by turning off V-Sync and setting "Max frames to buffer" to 2 (or more, though higher numbers caused noticable input-lag for me).

The screen tearing is terrible, but at least the game is playable.

0

The kind of freeze you are describing means that you dont have enough RAM to play the game, GPU problems lower the framerate but never freeze the game. I had 4GB RAM on my old pc and had the exact same thing. Now I have 8GB with the same GPU and I can play it flawlessly.

0

I don't think the problem you're describing is due to your amount of RAM or your GPU as you/others have pointed out, but rather your RAM's clock speed. When moving around the world you're rendering the parts you're headed towards, if the RAM takes too long to load this it may result in these freezes/fps drops while moving, more notably while moving quickly, like in a vehicle. The only solution I could propose is to purchase RAM with a higher clock speed. This is of course assuming you currently like 8GB+ of RAM, otherwise I'd recommend purchasing more as @Elgert said.

Not the answer you're looking for? Browse other questions tagged or ask your own question.