Whenever I boot up TF2, I get a black screen but can hear the audio. I am using a Benq external monitor. If I unplug the monitor and use my laptop screen and reboot TF2, it loads fine. I can, however, get windowed mode to work on my external monitor. I have tried reinstalling TF2, and it hasn't helped. Also, other Steam games work, so that's not an issue. Any ideas on what's happening?

  • No clue why. As a workaround, would going borderless on your external monitor be acceptable?
    – Schism
    Jun 22 '14 at 2:41
  • Hi! Thanks for contributing to the site. It's nice to meet you. Just to let you know, the standard of this site is to keep things in a question and answer format. For that reason, we try to keep things like a TIA message out of the question, as they fit more of a chat narrative. I don't have any insight on your question (other than to try updating the video driver), but hopefully someone else will be able to help more.
    – Brythan
    Jun 22 '14 at 3:15
  • What OS, CPU, GPU, and GPU drivers are you using? Jan 3 '16 at 11:09

According to this page, disabling Multicore Rendering in TF2 video options stops black outs.

Otherwise, like you said, this workaround works:

  1. Rightclick the game in your Steam library.
  2. Click "Properties"
  3. Click "Set Launch Options..." in the "General" tab.
  4. Use these launch options, where 1920 and 1080 are your gaming display resolution:

    -w 1920 -h 1080 -windowed -noborder

If that doesn't work, try -dx98, -dx95, or even -dx80 to use less advanced GPU features. -condebug might provide hints in Steam\steamapps\common\Team Fortress 2\tf\console.log

Up- or downgrading your video drivers might also help.

If you're still having display issues in other programs as well, check the video card for insufficient cooling and clean/replace if needed.

  • Apps like f.lux also interfered with TF2. Jun 18 at 8:06
  1. Open TF2 on your benq monitor.

  2. Change the resolution to the lowest that there is.

  3. Restart Tf2 on your laptop with no external monitors.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.