3

I've been playing this world for a while now and I have been able to collect cobblestone just fine, but suddenly whenever I destroy a block, it's not going into my inventory. I have tried a wooden, stone and iron pickaxe, but none of them have worked. I have closed the program down and started it up again, and it let me play normally for about 10 minutes, but then started again.

Does anyone know how to fix this?

25
  • does the block break instantly?
    – Rapitor
    Jun 23, 2014 at 14:33
  • No. it does it completely normally. it even breaks faster when i use a better pickaxe. The stones just not going into my inventory.
    – Liam
    Jun 23, 2014 at 14:35
  • 1
    Maybe a bit of a stupid question, but is your inventory full?
    – user79446
    Jun 23, 2014 at 14:36
  • 1
    it happens with every block ive tried. wood, stone, iron. and yea they do crack but nothings on the ground or inventory. ill try creating a new world and see what happens
    – Liam
    Jun 23, 2014 at 15:05
  • 3
    yea its letting me collect blocks normally. thank you, guys.
    – Liam
    Jun 23, 2014 at 15:24

2 Answers 2

5

From looking at the exstensive discussion in the comments, it has appeared as though you had doTileDrops set to false. Change this by entering in /gamerule doTileDrops true. Hope this helps!

1

If you mine stone with a pickaxe you will get cobblestone. If you mine stone with a silk touch enchanted pickaxe, you will get stone.

Try clearing out you entire inventory except for a pickaxe, go mine some stone and see what you get, if you get cobblestone then that's normal. If you get nothing THEN there's an issue. In order to get stone it can either be created in a furnace or mined using a silk touch enchanted pickaxe.

EDIT: Try 1. Creating a new world 2. Restarting your computer 3. Send the command /gamerule doTileDrops true

4
  • 1
    oh sorry i mean no cobblestone is entering my inventory. im not using a silk enchanted pickaxe.
    – Liam
    Jun 23, 2014 at 14:53
  • Is it stacking up, is it not even dropping after you mine the block, what does it do when you mine it.
    – Jonco98
    Jun 23, 2014 at 14:58
  • 1
    when i mine it, the blocks cracking and breaking but nothings appearing on the ground or in my inventory. also i tried to dump everything in my chest and mine some stone with just my pickaxe in my inventory but found out that its not letting me access my chest or anything. its just letting me break stuff and not collect anything. so, the issues might be related or something
    – Liam
    Jun 23, 2014 at 15:01
  • Try what Travis said, try mining a different block and see what happens...
    – Jonco98
    Jun 23, 2014 at 15:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .