2

During one of the imperial attacks on a stormcloak fort, I accidentally picked up a new horse. This caused Shadowmere to disappear (he had wandered off during the fighting) and I've been unable to find him. I've checked both sanctuaries, no luck there, and I've killed the new horse and waited a while. No shadowmere.

I've lost Shadowmere - where can I find her? I've found this answer, but the difference is that I'm not sure where I got the new horse. I can't use commands since I'm on xbox.

Any tips, or will I have to say goodbye to my favorite destruction trainee?

  • Are you sure that you've waited the requisite amount of time? – NiteCyper Jun 27 '14 at 5:24
  • Maybe Shadowmere decided that if you're off riding other horses, she's better off without you. She's a strong, independent filly and she doesn't need to put up with you any more. – Alex Jun 27 '14 at 11:31
5

There is a good chance that she is dead. Return to the position from where you fast traveled and you will probably find her corpse. Kill all the enemies in the region and wait 10 days, then she should appear when you fast travel again since companions are reset after 10 days if they die. If she doesn't appear, check the small lake in front of the falkreath sanctuary.

If not, try buying another horse and kill it. Shadowmere should become your default horse then and might "respawn" when you fast travel.

| improve this answer | |
  • I'll try this later tonight. The problem is, I'm not entirely sure where I last saw her, and which attack I accidentally got the new horse from. – Blue_Dragon360 Jun 27 '14 at 18:04
  • Neither of your suggestions worked. I thought I remembered that I picked up the new horse at fort green wall, so I waited there. No luck. – Blue_Dragon360 Jun 28 '14 at 3:59
1

The only choices are:

  • Shadowmere died. Wait for a few days and go back to the place he died the retrieve him.

  • Go to the nearest stable where your horses would be. Shadowmere should be there [It that doesn't work, try fast traveling into the city as horses will be at the stable].

  • Go to console and type the following:

    1. prid 0009CCD81

    2. moveto player

Shadowmere should teleport back to you.

This worked for me, and it works for others so this answer might suit you.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.