2

I've downloaded the Crysis 2 demo through Stream, but when I try to run it I immediately get the error message

Failed to initialize the GameStartup Interface!

and nothing happens after clicking the "OK" button. What causes this problem, and how can I fix it?

System specifications:

  • Windows 7 64bit.
  • Nvidia Geforce 250 GTS, with latest drivers.
  • All other PC stats also matching or exceeding minimum requirements as specified in the Steam Store page.
  • 1
    Please provide more Info: OS, GPU, current drivers, any overclocked component etc. – DrFish Mar 2 '11 at 9:25
  • 1
    Agreeing with Bora. We need more information. Additionnaly, did you verify the game fragmentation, through the game options? You could consider suppressing crysis2 .gcf, then re-DL it, it could resolve your problem... – Lysarion Mar 2 '11 at 9:29
  • The GPU seems a little faint for this monster of a game. – DrFish Mar 2 '11 at 10:25
  • @Lysarion verifying file integrity has solved the problem; please migrate your comment to an answer so I can accept it :) – Oak Mar 2 '11 at 10:40
  • Added answer. I also put some details about potential origins. It may need a spellchecking, i fear i made some errors, since i'm french... Could you check it? – Lysarion Mar 2 '11 at 12:46
3

This kind of error can sometimes be solved when you verify the game fragmentation, through the game options.

Game fragmentation usually happens when you download too many games at once through Steam, or when a game is being downloaded by too many people at once.

It can also be caused by running a process which does a lot of disk access.

  • 2
    It wasn't precisely a fragmentation problem... but choosing "verify integrity of game cache" in Steam fixed the error. – Oak Mar 2 '11 at 12:52
  • Yup, but usually (at least with source-engine based games), interface-initialization's problems come from highly fragmented game files, and asking Steam to chek fragmentation also forces a presence-check for all of the game files. That's why i was suggesting it in the first time, since it could have resolved those two problems. – Lysarion Mar 2 '11 at 13:12
2

I had the same error. This is how I fixed it:

Copy all .dll files from the "bin32" directory and paste them in the main directory.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.