3

Often when I want to play survival singleplayer in Minecraft, I can't. This is due to chunks taking ages to load whenever I move to a new area of my map, leading me to regularly hit the esc button to help load the chunks faster. After being tired of this regular behavior of chunk loading, I decided to open up task manager to see how my computer was performing. Now, RAM isn't an issue, but when ever I load new chunks, the CPU usages goes up to almost 90%. Once it even got up to 93%! Is there anything I can do to diagnose the problem?

I'm running windows 7, Minecraft 1.7.10, with a view distance of 7.

  • 3
    Please can you let us know your computer spec. e.g. cpu details and ram details, which version of ram and also which version of minecraft – Flaunting Jul 14 '14 at 14:15
  • 2
    Not necessarily, if you don't have enough physical ram your OS will spend all its time writing memory to the hard drive so it can load other pieces of memory to ram again. - This is noted as CPU usage. – Elva Jul 14 '14 at 14:20
  • 3
    @Studoku That's a straight up Windows function. Run out of RAM, start paging to hard drive. You run Windows, it happens automatically. – Frank Jul 14 '14 at 14:26
  • 1
    also can you mention what view distance you are running – Flaunting Jul 14 '14 at 14:29
  • 2
    At work, Minecraft 1.7.10 consumes 100% of one core, pretty much all the time. It appears to tickle another core during chunk loading, as the cpu usage for the java process running minecraft goes above 100% ( as high as 135% ). This is running on Fedora Core 20 x86_64 with 12gb ram. I am also running off a very slow, cheap SSD (240gb Kingston ) and a very underpowered nVidia GT 530. I am using a render distance of 16, and all the settings maxed out pretty much. I have the following memory allocations defined in the bootloader: -Xmx2G -Xms2G I never see chunk lags on local or multiplayer. – Therealstubot Jul 14 '14 at 21:02
6

Do the following steps and it should improve your performance.

  1. Update/Reinstall Java - Delete your current version and do a fresh install of the latest version.

  2. Assign as much Ram as your computer can muster - the more ram that minecraft has to work with the better it will perform, and the less dependant it is on your other hardware. - i go overboard and have assigned 14gb to each of my MC versions. but i have found that 2gb is perfect for vanilla and 4-6 is fine for ftb to have good performance with far view distance.

  3. Try reinstalling MC - Backup all your saves and reinstall your .minecraft folder.

  4. As an added measure install optifine - the installer is easy to use now for minecraft & doesn't require forge - this should help boost performance a little bit further.

Me personally i would do all the steps above (maybe not optifine depending on whether the others worked) this is quite a big issue to have and without the system specs and java version i have to give a more generalised answer. If this doesn't work i would say that your system can't handle the game on that view distance and you need to lower it.

Let me know if you need more info or if this doesn't work and I can talk you through a more complicated way of improving performance.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.