-1

I accidentally turned on danger mode and the hostile mobs started to spawn. I turned it off, but for some reason, they are still here.

I went to sleep and went out the house and they were still there. I killed all the ones next to me and later that night more were outside, even though in settings it says I'm on easy/peaceful mode.

I live by a huge forest, so they are all over my house! Please help me! I have Minecraft version 0.9.0

(I already tried to leave and turn off the game and go back, it didn't work)

How can I stop hostile mobs spawning?

  • 2
    which difficulty, easy or peaceful, you can't be both as easy will have hostile mobs but peaceful wont – Memor-X Jul 16 '14 at 2:16
  • 2
    What is "danger mode"? Of everything I know about this game I have never heard anything like this. Monsters spawn at night, they hate you day and night (with the exception of spiders). Are you thinking of creative? – Ben Jul 16 '14 at 2:23
2

From the "Pocket Edition" page on the wiki:

If you are feeling overwhelmed by hostile mobs, turn on Peaceful mode in the options menu by moving the difficulty slider to the left.

This is the options menu with the difficulty slider all the way to the right, you need to slide it all the way to the left to change to peaceful difficulty (without hostile mobs).

Options

0

This game has several functions to determine when and where monsters will spawn:

  • Difficulty

The only difficulty in which monsters will not spawn is "Peaceful". Anything higher will cause monsters to spawn including "Easy". If you return to Peaceful, any mobs that have spawned, will despawn.

  • Game mode

There are two game modes: Creative and Survival. While this does not determine whether or not monsters will spawn, it will determine their aggressiveness toward the player. In Creative monsters will not be hostile, however they will still spawn and wander around aimlessly until attacked directly by the player. In Survival monsters will be hostile toward you once they enter a certain radius. Note: I'm not sure if this is a feature in pocket edition.

  • Light level

Once it gets dark enough monsters will begin to spawn. This is true for nigh and day, in forests, caves, or unlit structures that you have made. Placing torches around the areas will stop this from happening.

  • Distance

The distance in this game is measured by what is defined as "Chunks" that are loaded and unloaded when a player moves around the map. When a chunk is unloaded, any hostile entities (or mobs) will despawn after a certain time.

0

It is a bug which I have also experienced in 0.9.0, I am currently in 0.10.4 and monsters spawned from eggs in creative don't despawn when I turn on peaceful.

But the problem is: A bug

0

Monsters don't spawn on glass blocks. You can also try to make monster traps. The most effective for me is to surround your house in cacti.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.