6

I got NEI for minecraft 1.7.10. But when I try to use it in survival to find recipes it gives me a stack of the item I click on.

How do I stop this from happening?

7

You can open the player inventory and you will find a button in the bottom right-hand corner that alternates the mode of the NEI, and you want "Recipe Mode" the others are "Cheat Mode" and "Usage Mode".

Alternately while hovering over the item you want you can press either "R" to show the recipe or "U" to show the usage.

| improve this answer | |
  • It is on recipe mode is there a way to turn off the cheating altogether so I don't have to press R and I can just click and it will show me the recipe?? – andy6752 Jul 16 '14 at 7:15
  • @andy6752, it is possible... Just look at this question... Well Answer: gaming.stackexchange.com/questions/177040/… – aytimothy Jul 16 '14 at 11:56
  • @andy6752, yes, the first part of my answer provides the answer to that, without having to edit config files – Ben Jul 18 '14 at 6:08
1

What you are looking for is go to the NEI options menu and look in the upper right corner where it says "Global" or "World".

Enter the "Inventory" menu and then click on the "Global" or "World" button you will see that one of the two screens is probably set to cheat mode.

Just change it to recipe mode then click the "Global" or "World" button again and change the other one to recipe mode also

since NEI is Universal it gives you the server options as well, which are set to cheat by default i think??? confirmation?

problem solved

| improve this answer | |
0

You have cheat mode enabled in NEI (the default), to use it for it recipe functionality you have to open your inventory, then click the options menu in the bottom left and change the NEI-mode to recipe mode instead of cheat mode.

| improve this answer | |
0

Check the config file for NEI. There's a "lock" state which tells NEI to stay in that state no matter what you tell it in the game. that's probably set to cheat mode, so even though you change it to recipe / utility mode in the game, it's locked to cheat mode.

I'm at work so i can't tell you exactly where and what to change, but it should be in your NEI mod folder or the configs folder.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.