16

When I started Minecraft for the first time after installing OS X 10.10, OS X presented me with this: OS X screenshot

This happens even after the installation of JDK 8u20, which makes it even more confusing. I don't want to install an old-as-balls version of Java, I want Minecraft to use the existing version. Can I somehow force it?

  • As much as it is 'old-as-balls' Java 1.6 was one of the best. – Sk4llsRPG Aug 2 '14 at 11:35
10

Mac OS X 10.10 Yosemite is still Beta software as of July 2014. I wouldn't expect Minecraft to be updated for the new operating system until it is released. Maybe not even then if they still haven't updated it for version 7 which is more than a year old.

  1. First make sure you have the latest Minecraft launcher: download here: https://minecraft.net/download

  2. Then follow these instructions here to update the minecraft java version and architecture. (I don't have Java 8 so let me know if the paths are not correct) http://blog.fnaard.com/2011/11/minecraft-on-mac-os-x-with-64-bit-java.html

Launch the new app!

If you can't get this to work please let me know how far you got.

Other references:

General mac minecraft install tips: http://www.minecraftforum.net/forums/support/unmodified-minecraft-client/tutorials-and-faqs/1871626-mac-support-101

Another way to use a newer version of Java with Minecraft for Mac (scroll down for updates) http://www.minecraftforum.net/forums/support/unmodified-minecraft-client/1858141-minecraft-x64-for-mac-with-java-7#entry21096898

Bug report for Minecraft not recognising the current Java version: https://bugs.mojang.com/browse/MCL-1049

Another way to update the Minecraft app for Java 7 (requires additional software) http://kovuthehusky.com/blog/running-minecraft-on-os-x-using-java-7/

  • 8
    Replacing Minecraft.app's JavaApplicationStub did nothing, but invoking Java from the Terminal worked: java -d64 -jar /Applications/Minecraft.app/Contents/Resources/Java/Bootstrap.jar – Peter W. Jul 27 '14 at 10:04
7

Ever since the new Minecraft launcher was released back at version 1.6, it is no longer necessary to mess around with application bundles or command line trickery to change the version of Java you wish to use.

The Minecraft Launcher itself will still require Java 6 on Mac, but Minecraft itself will launch with the version that you specify in the launcher.

Here is how you change it:

  1. First of all, you need to install the Java 8 JDK. The JRE only works as a browser plugin.

  2. You will also need to install Java 6 to use the launcher. Follow the instructions you were given when you tried to run the launcher.

  3. Once the launcher is running, click Edit Profile

  4. Under Advanced Settings, click the Executable checkbox, and enter the path to the java binary of the version of Java you wish to use. Each revision of Java 7 or Java 8 is stored in its own directory so check the path in Finder to make sure you have the correct directory. My Java 8 path is as follows:

    /Library/Java/JavaVirtualMachines/jdk1.8.0_20.jdk/Contents/Home/bin/java

  5. You may wish to increase the amount of memory that Java uses by clicking the JVM Arguments checkbox. My setting is as follows:

    -Xmx1G -XX:+UseConcMarkSweepGC -XX:+CMSIncrementalMode -XX:-UseAdaptiveSizePolicy -Xmn128M

  6. Now save your profile, and launch Minecraft. You can verify the version of Java you are using by pressing F3 during gameplay and looking in the upper right-hand corner.

  • The JRE only works as a browser plugin +1, I didn't realize this. Installing the JDK fixed everything. – Qix Feb 14 '15 at 18:42
  • It's too bad it's blatantly false. The JDK is the Java Development Kit. – Tom G Mar 10 '15 at 1:02
  • Try again. The Java 7 and Java 8 JRE is a browser plugin ONLY. There is no Java binary. For the ability to run JAR files, you MUST install the JDK. You cannot run Jar files with the JRE. – teilo Mar 11 '15 at 1:57
  • You are evidently thinking of Windows. But on a Mac there is no equivalent to Java.exe in the JRE. See here: docs.oracle.com/javase/7/docs/webnotes/install/mac/mac-jre.html Note the following: "Installing a JRE from Oracle will not update java -version symlinks or add java to your path. To be able to do this, you need to install the JDK." – teilo Mar 11 '15 at 2:04
2

Here are two easy answers:

(1) Don't install Java 6 (the old version from Apple). Instead head to Oracle's website and install Java 8. Now head back to Minetcraft.net and download the Linux version of Minecraft. Extract the "Minecraft.jar", double click to start, and answer a few security questions.

(2) Wait. According to reddit post in December 2014, Mojang will bundle an appropriate Java with a future Minecraft launcher. This will run in 64 bit on 64 machines, and reduce potential Java version confusion. The download will increase in size from approximately 40mb to 60mb.

Mojang writes that Minecraft works best on Java 8 (and not Java 7!).

1

I successfully use the following command with no issues. It is here in Applescript form so you can save it as an .app for each launching:

do shell script "\"/Library/Internet Plug-Ins/JavaAppletPlugin.plugin/Contents/Home/bin/java\" -d64 -Xms4096M -Xmx5130M -jar /Applications/Minecraft.app/Contents/Resources/Java/Bootstrap.jar"

protected by Community Dec 1 '14 at 1:23

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.