0

So I wanted to set up something that uses stat.mineBlock.snow, but it wouldn't work. I tried other stat.mineBlock, but they wouldn't work either. I did the command /scoreboard objectives add snow stat.mineBlock.snow Snow But it returns with Usage: Invalid objective criteria type 'stat.mineBlock.snow' So what am I doing wrong, and how do I fix this?

  • I see the bigger problem. I've had trouble with other things that have to do with the new name system. I did the new objective but only with the snow ID, and it worked. So, for some reason I can't use the names in commands for some unknown reason. Should I start a new question for this? – user3583094 Jul 30 '14 at 17:37
4

Even though it seems you got it working by using the numerical ID, there is a way to add it by using the friendly names. instead of stat.mineBlock.snow, it would have to be stat.mineBlock.minecraft.snow.

0

You forgot to put criteria.

http://minecraft.gamepedia.com/Scoreboard#Criteria

/scoreboard objectives add stat.mineBlock.snow (Criteria)
  • This is incorrect; the OP's syntax was in the correct order. On the same page linked is the syntax: /scoreboard objectives add <name> <criteria> [display name...], in which the criteria comes after the name. The name the OP specified is "snow" with the criteria being "stat.mineBlock.snow". The issue was an invalid criteria name due to the missing prefix "minecraft", as explained in the other answer. – Skylinerw Jan 27 '17 at 23:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.