4

I'm running a Bukkit server, on which I am trying to use Command Blocks to run commands. In one Command Block, I have tried to use save-all, but when activated, nothing happens

The command sudo works, as i tried /sudo @a gc

But the sudo command doesn't work with save-all either.

  • Where you get the sudo command? There no such command in a original server or bukkit server... – Gerret Aug 3 '14 at 15:47
  • 1
    It's a part of the essentials plugin for bukkit servers – EpicMinecartz Aug 3 '14 at 18:09
1

The syntax for the sudo command is /<command> <player> <command [args]> and its description is Make another user perform a command. With the command /sudo @a gc you force every player to execute /gc. Means everyone see the server usage information.

If you typed /sudo @a save-all in the commandblock, be happy that it dosen't work because that could be ending in a server crash. (Everybody on the server is forced to execute the command /save-all, what needs much hardware usage)

What I think that you missleading it with the sudo command from linux where the command is executed as root.

The problem why you can not execute the command /save-all in a commandblock is because it is disabled from the server itself for security reasons.

In the Minecraft Wiki you find that information:

These commands are likely disabled due to limited use in command blocks and the potential for severe, unintended consequences on servers.

That counts for the commands:

ban, ban-ip, deop, kick, op, pardon, pardon-ip, save-all, save-off, save-on, stop, whitelist add/remove/on/off/reload, debug, publish

If you really need that command, the only possibility is to use a command of a other plugin and not the original command /save-all.

But make sure that it is executed only once! Keep in mind that griefer could use it to crash the server by expensive hardware usage if they spam the button!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.