The problem: when I am downloading anything with Steam, no matter where I am or what I am connected to, it pauses the download after a few seconds.


  • Select item to download
  • Navigate to library -> downloads
  • [probz] Game is displayed "downloading", network speed listed, etc (normal behavior)
  • [see Picture 1 below]
  • After a few seconds, game stops downloading
  • Game is now listed as "update required (not queued)"
  • [see Picture 2 below]
  • Click "move to top of queue"
  • goto [probz]

Picture 1

enter image description here

Picture 2

enter image description here

I can workaround this by babysitting the "move to top of queue" button but for large games this isn't practical.

Things I have tried:

  • Wired connection
  • Using a different network (many, many different networks)
  • Changing Steam download server/location
  • Reinstalling Steam
  • Deleting tons of Steam files and redownloading them
  • Freeing up disk space
  • Changing download speed/limit on Steam
  • Stopping background programs/other internet accessors
  • Adding "-tcp" flag to Steam launch options
  • Running as administrator
  • Crying

This is a problem I've been having for some time and have tried many solutions (see above). I'd love to see a definitive solution to it, especially since I pretty much can't play any game > 1 gb.

OS: Windows 7 Professional, 64-bit

System: Lenovo T420 (laptop), Intel i7-2620M, 8gb ram, NVIDIA NVS 4200M

Connection: Up to 45 mpbs AT&T UVerse (usually clocks in at around 30-something)

EDIT: I would like to note that I used to work in CS (see my Stack Overflow profile), so I do know how to do things like "make sure your internet connection works", "don't let other programs hog bandwidth", and "disable background processes". Because my internet connection works perfectly for everything else I do, including high-bandwith activities (gaming, netflix, other downloading) I would guess that it is not the problem. Especially since I can workaround through queue babysitting (see above). The ONLY problem I have is with Steam, and ONLY when downloading new games.

Thanks for the suggestions so far.

  • Probably lack of disk space. Happens to me every now and then.
    – user98085
    Commented Aug 5, 2014 at 19:17
  • I have 38 gigabytes free, just cleaned out all the games I don't play anymore.
    – Dustin
    Commented Aug 5, 2014 at 19:19
  • System specs? OS?
    – Batophobia
    Commented Aug 5, 2014 at 19:26
  • Edited to add, although I am hoping it's a generalize-able problem.
    – Dustin
    Commented Aug 5, 2014 at 19:31
  • 2
    Do you have multiple hard drives? Can you verify which hard drive your steam library is on? Commented Aug 5, 2014 at 22:09

2 Answers 2


Try disabling ANY processes that might interfere with your downloading (I fixed mine by disabling Skype). You can find the processes here: https://support.steampowered.com/kb_article.php?ref=9828-SFLZ-9289 Let me know if this helped!

  • Honestly, I'm just gonna mark this as the correct answer. I did a fresh install of Windows on my computer and that fixed it. Very helpful information though.
    – Dustin
    Commented Jan 10, 2015 at 0:22
  • This didn't work for me... the only program I had on that list was AnyDVD, I quit that, restarted Steam, still no joy. Changed my region to the nearest "(Comcast)" labeled region (since Comcrap is the only real broadband provider in my area) for best peering, restarted Steam again, and now it seems happy. Changing to another nearby (but not Comcast-labeled) region did not help me either.
    – Doktor J
    Commented Feb 16, 2015 at 6:13
  • Worked for me on Windows 10
    – Martin
    Commented Oct 6, 2015 at 20:22

Have you tried changing the download restrictions Steam asks you for when changing the download region?

enter image description here

You can get there by clicking Steam --> Settings --> Downloads

When you change your region, you should be prompted to change your download speed (Modem towards faster speed, Dial-Up towards slower.

Could be the issue you're having. I have had this issue previously, but by changing my download speed to No limit (despite having an average 2mb/s), it helped fix it.

I would daresay this though; it seems plenty of others are having the same issues as you have as well, albeit for different reasons.

  • Yes that's the other thing that can affect it. Try switching your preferred region to somewhere else and see if it improves the situation
    – l I
    Commented Aug 6, 2014 at 0:49
  • I just checked the download restrictions - it is set to "No limit". I have tried many different regions as well. :/
    – Dustin
    Commented Aug 6, 2014 at 2:13
  • Thanks for the suggestions, I've been looking for a solution for quite some time. The problem is that most other problems have to do with internet connection, which isn't the problem (since I can workaround through babysitting the download).
    – Dustin
    Commented Aug 6, 2014 at 2:16
  • @Dustin I'll also wager a guess, but I've been having this problem on and off, and I believe it may be tied to having a "no Download Limit". I've checked here: support.steampowered.com/kb_article.php?ref=9498-WPDF-3220, and Steam recommends setting the download speed to the one CLOSEST to your actually connection. At this point though, it's just a guess, so naturally, what is your internet/ISP connection speed?
    – childe
    Commented Aug 6, 2014 at 2:18
  • It's 45 mbps ("up to", usually checks in at around 34). ATT Uverse. Had this problem with my last provider as well. Also anywhere else I use my laptop. I'll try setting the speed. EDIT: does not appear to help
    – Dustin
    Commented Aug 6, 2014 at 2:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .