7

I hadn't played Minecraft in a few days prior to this, but when I fired it up, I had no sounds whatsoever, either in the menu or the game. First thing I checked was in-game, and all audio settings were set to 100%. I then tried the "Hold-F3-and-push-S" thing, and that had no effect. I then deleted the entire .minecraft folder (after having copied my saves out) and reinstalled, and even deleted my Minecraft.exe and re-downloaded it from minecraft.net. None of those had any effect.

I tried downloading a sounds set, with no effect. I looked in the assets/indexes/1.7.10.json file to see what files were there, and verified that the sounds exist. For example, I checked the walking on grass sound, found the file, made a copy to .ogg and played it in VLC, and it played fine.

I rebooted into Fedora and played the java version (same computer) and it plays the sound just fine, so I'm wondering what the issue is with Windows 7.

Anyone have any suggestions?

  • Three questions. 1: Did you check to make sure that other Windows 7 sounds are also working? 2: Did you try reinstalling the entire game? Making sure to first un-install the game and then re-download it? 3: Did you try updating to the latest version of Minecraft? I believe there is a more up-to-date version. – Zibbobz Aug 7 '14 at 17:44
  • 1. Yes, everything else has no sound issues at all. 2. Yes, I deleted everything and reinstalled. 3. There really is no uninstall, because there's no installation aside from the .minecraft folder creation that happens automatically when you run the game. Edit: I also rebooted between deletion/reinstallation. – Tim S. Aug 7 '14 at 17:48
  • I should also point out that this installation worked for a year+ without issue, and no hardware changes happened in that time aside from a power supply replacement. – Tim S. Aug 7 '14 at 18:07
  • Did you try clicking on the sound icon and choosing "mixer" while minecraft was open? You may have turned it off in another Java program, or even minecraft itself. If this doesn't work, I would attempt to reinstall Java. – Blue_Dragon360 Aug 7 '14 at 21:02
  • Looks like I fixed this after all. @Blue_Dragon360 I did look at the mixer, however minecraft never showed up there. On a whim, I clicked on "Playback devices", then "Configure" on the default speakers icon, and changed it from "Surround" to "Stereo", and lo and behold, it started working. I've had it on surround forever, so I have no idea why it matters now. Regardless, it's working now. Thanks for the suggestions. – Tim S. Aug 7 '14 at 22:13
14

If you still don't have sound or can't find Minecraft in the volume mixer, try to change the "Mipmap Levels" option in video settings (under "Quality" when using Optifine).

It works for many people and it also worked for me. You can also put it back to your desired settings afterwards. :)

  • Thanks! This solved the sound issue on Windows 8 and Minecraft 1.8.9 – Akseli Palén Dec 26 '15 at 18:17
  • 1
    Also worked for me, Minecraft 1.8.0, windows 10. – Winger Sendon Mar 5 '16 at 14:36
  • Worked on Minecraft 1.12 Win 10 Optifine – Marc Jan 10 '18 at 17:13
  • Thanks a ton! Couldn't figure this out, so frustrating, but this worked like a charm! – GlyphGryph Jun 17 at 1:54
7

I ended up finding this myself, with help from @Blue_Dragon360, who suggested looking at the mixer.

(from previous comment -- I couldn't answer the question at the time -- too soon)

I looked at the mixer, however minecraft never showed up there. On a whim, I clicked on "Playback devices", then "Configure" on the default speakers icon, and changed it from "Surround" to "Stereo", and lo and behold, it started working. I've had it on surround forever, so I have no idea why it matters now. Regardless, it's working now. Thanks for the suggestions.

  • 1
    Not trying to rep-whore this, so not upvoting or answering my own post unless that's what I'm supposed to do. – Tim S. Aug 16 '14 at 20:43
  • You can't really upvote your own question, but great job anyway :) – Timtech Nov 11 '14 at 16:49
4

Is only Minecraft muted? It is possible to mute per app. To check this, go to your Sound taskbar icon, click it, click Mixer, and check Minecraft.

Screenie: Screenshot

The above answer is Freehand-Circle compliant, in accordance to the StackOverflow FreehandCircle Code, Chapter 47, Section 4, Paragraph 3.1

1

Adding this answer for others desperately looking to fix their sound issues:

I just figured out my Minecraft sound issue. Spouse and I had sound, but the kids haven't since the 1.9 upgrade. After trying a number of suggested fixes with no luck, I discovered that my Windows Family Safety settings were blocking Minecraft's ability to download the new sound packs. Apparently the message box appears just after the launcher closes and disappears almost immediately, so if you're not watching closely for it, you'll never know there's an issue. I changed the permissions, and voila! Sound!

1

If you have a texturepack DISABLE it. Some texture packs does not only change texture but some change sound and then they mute you minecraft volume.

1

It might sound funny, but in my case changing Anisotropic filtering in Video Quality settings unmuted the sound :)

-2

Go into uninstall and change programs in control panel click on minecraft and click repair about 5-7 times it will not destroy saves but some of the runtime will be installed next boot

protected by Timmy Jim Oct 29 '17 at 17:06

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.