-1

Every time I try I get this JsonSyntaxException:

---- Minecraft Crash Report ----
// Ouch. That hurt :(

Time: 8/8/14 8:59 AM
Description: Starting integrated server

com.google.gson.JsonSyntaxException: java.lang.IllegalStateException: Expected BEGIN_ARRAY but was STRING at line 1 column 1
at com.google.gson.Gson.fromJson(Gson.java:815)
at com.google.gson.Gson.fromJson(Gson.java:768)
at ns.b(SourceFile:156)
at ns.<init>(SourceFile:42)
at net.minecraft.server.MinecraftServer.<init>(SourceFile:114)
at bsx.<init>(SourceFile:38)
at bao.a(SourceFile:1610)
at bdx.e(SourceFile:162)
at bdx.a(SourceFile:127)
at bdw.a(SourceFile:172)
at bdw.k(SourceFile:232)
at bdw.p(SourceFile:211)
at bao.p(SourceFile:1328)
at bao.ak(SourceFile:774)
at bao.f(SourceFile:728)
at net.minecraft.client.main.Main.main(SourceFile:148)
Caused by: java.lang.IllegalStateException: Expected BEGIN_ARRAY but was STRING at line 1 column 1
at com.google.gson.stream.JsonReader.beginArray(JsonReader.java:338)
at com.google.gson.internal.bind.CollectionTypeAdapterFactory$Adapter.read(CollectionTypeAdapterFactory.java:79)
at com.google.gson.internal.bind.CollectionTypeAdapterFactory$Adapter.read(CollectionTypeAdapterFactory.java:60)
at com.google.gson.Gson.fromJson(Gson.java:803)
... 15 more


A detailed walkthrough of the error, its code path and all known details is as follows:
---------------------------------------------------------------------------------------

-- Head --
Stacktrace:
    at com.google.gson.Gson.fromJson(Gson.java:815)
    at com.google.gson.Gson.fromJson(Gson.java:768)
    at ns.b(SourceFile:156)
    at ns.<init>(SourceFile:42)
    at net.minecraft.server.MinecraftServer.<init>(SourceFile:114)
    at bsx.<init>(SourceFile:38)

-- Starting integrated server --
Details:
    Level ID: New World
    Level Name: New World
Stacktrace:
    at bao.a(SourceFile:1610)
    at bdx.e(SourceFile:162)
    at bdx.a(SourceFile:127)
    at bdw.a(SourceFile:172)
    at bdw.k(SourceFile:232)
    at bdw.p(SourceFile:211)

-- Affected screen --
Details:
    Screen name: bee
Stacktrace:
    at bao.p(SourceFile:1328)
    at bao.ak(SourceFile:774)
    at bao.f(SourceFile:728)
    at net.minecraft.client.main.Main.main(SourceFile:148)

-- System Details --
Details:
    Minecraft Version: 1.7.10
    Operating System: Windows 8 (x86) version 6.2
    Java Version: 1.7.0_25, Oracle Corporation
    Java VM Version: Java HotSpot(TM) Client VM (mixed mode), Oracle Corporation
    Memory: 222667112 bytes (212 MB) / 377651200 bytes (360 MB) up to 523501568 bytes (499 MB)
    JVM Flags: 6 total; -XX:HeapDumpPath=MojangTricksIntelDriversForPerformance_javaw.exe_minecraft.exe.heapdump -Xmx512M -XX:+UseConcMarkSweepGC -XX:+CMSIncrementalMode -XX:-UseAdaptiveSizePolicy -Xmn128M
    AABB Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used
    IntCache: cache: 0, tcache: 0, allocated: 13, tallocated: 95
    Launched Version: 1.7.10
    LWJGL: 2.9.1
    OpenGL: AMD Radeon HD 7340 Graphics GL version 4.3.12618 Compatibility Profile Context 13.251.9001.0, ATI Technologies Inc.
    GL Caps: Using GL 1.3 multitexturing.
Using framebuffer objects because OpenGL 3.0 is supported and separate blending is supported.
Anisotropic filtering is supported and maximum anisotropy is 16.
Shaders are available because OpenGL 2.1 is supported.

    Is Modded: Probably not. Jar signature remains and client brand is untouched.
    Type: Client (map_client.txt)
    Resource Packs: []
    Current Language: English (US)
    Profiler Position: N/A (disabled)
    Vec3 Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used
    Anisotropic Filtering: Off (1)
  • 3
    1: You're actually missing 15 lines of error messages, but 2: Judging from the errors you have, I'd say there's something wrong with the code itself. Try re-installing if nothing else works. Also 3: Is this just when you try to play single-player, or have you tried and gotten similar errors playing multiplayer? – Zibbobz Aug 8 '14 at 13:29
  • This has been answered and confirmed fixed on this question and instead should be marked as duplicate of that one – Robotnik Apr 16 '15 at 5:16
  • @Robotnik Okay, probably, but isn't this the sort of thing to ask a mod for? I mean, it's a bit clunky to wait for 5 people to reopen, then 5 people to vtc... – Schism Apr 16 '15 at 6:07
  • @Schism - I did this earlier for 4 different questions, but I... don't like bugging the mods needlessly if I can avoid it. Perhaps you're right however. I'll flag it now – Robotnik Apr 16 '15 at 6:14
4

Some of the .json files in the minecraft installation or in the world are broken. From the information you have posted it is impossible to tell what file exactly. Try deleting everything except the saves folder in your .minecraft folder (it is in %APPDATA% folder on windows, just paste %APPDATA%\.minecraft in windows explorer to locate it). Be careful not to delete the saves folder - your worlds are stored there and you don't want to lose them. After that run the launcher. You'll have to re-create your profile in the launcher.

If that doesn't fix it, the problem is in your world. Carefully navigate to .minecraft\saves\yourworldname\stats and delete the .json file(s) there. You'll lose only your statistics.

|improve this answer|||||

Not the answer you're looking for? Browse other questions tagged or ask your own question.