So I've been playing Skyrim on the PC and just noticed my game always crashes around the perimeter of quest item "Call Odahviing to Dragonsreach" on The Fallen.

To go back to a save that is not corrupt, I had to go from save where I'm at level 93 to a save where I'm at level 85, which was on 3/27/2014. Needless to say, I've done a lot since 3/27/2014.

What I'm tried to fix corrupt save:

  • Took out all mods
  • Tried mod Rogue Script remover
  • Tried mod SKYRIM Save Cleaner
  • Tried scan disk for errors, which there were no errors
  • Completely uninstall Skyrim
  • Other things I can't even remember

So I'm thinking because I can't recover my save, I've thought of a few ways to work around the corrupt save maybe someone can tell how to do:

  • Maybe using console I teleport myself to the location I need to be? This most likely won't work because it'll crash. However I'm willing to try it.
  • Use the older save and with the console auto-complete the main quest up to "Call Odahviing to Dragonsreach" on The Fallen.
  • Somehow fix my corrupt save!

1 Answer 1


Never add/remove mods from a game in progress. Modding in skyrim is a bit buggy, and removing/adding mods during gameplay fucks up a lot of the scripts that run in the background.

So if you add mod, start over from the beginning. If you remove one, do the same.

Yes, this is very annoying. But sadly that is the only way to keep your games from not being corrupted.

But the important lesson. NEVER add or remove mods to a running game. (as far as I heard it still can crash even with all the additional tools and steps. It is best to not change mods, to keep your save clean).

Call Odahviing to Dragonsreach

First of all, I don't think this is a quest item. I think you mean this as a step in the fallen quest. If this is what you mean.

You could try to use console commands to force the quest to the next step. Look at the quest stages and advance the quest to the last one. You will miss out on some stuff, like the dialogue, and there is a chance that the next quest does not activate properly. But this is what you could try.

Disk space

One possible problem for save corruption is running out of diskspace during playing. Happened to me once. So make sure you have enough space on the disk where the saves get stored. (Default is your 'My games' directory).

Related question

This question has been asked before, see : how-to-fix-corrupted-save-files-in-skyrim

Teleport command

See this question: What is the proper teleport command in Skyrim?

  • This is an old question but I'll add this here - it really depends on WHICH mods you add or remove. My character is level 88 and through the course of the game I've added and removed quite a few mods, mostly textures/meshes and these appear to have no effect on stability. However, if I have added a script or another larger mod which I then want to remove, I tend to go back to a save which was created before that mod was added. At level 85 I added SKSE, SkyUI and the Unofficial Patch and have had no issues. So it's really a case of YMMV.
    – C26
    Jan 14, 2021 at 12:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .