1

So me and my friends manged to make a server in Minecraft for us to play on and we would like to add mods. But the mods we want to add are a few versions lower than the updated version. Is there any way of making a server with a lower version of Minecraft that people can still play on?

3

I think what you're asking is how to download the correct server release from Minecraft, because the download page always lists (just) the current version.

Fortunately, the download link is consistent. The current link is:

https://s3.amazonaws.com/Minecraft.Download/versions/1.7.10/minecraft_server.1.7.10.jar

So, you just alter the versions a bit, and you've got it. For 1.7.2 it would simply be:

https://s3.amazonaws.com/Minecraft.Download/versions/1.7.2/minecraft_server.1.7.2.jar

And for 1.6.4:

https://s3.amazonaws.com/Minecraft.Download/versions/1.6.4/minecraft_server.1.6.4.jar

As others mentioned, you need only to modify your client profile to indicate which version you play on your end, and then you'd install the mods in whatever way your mod loader needs them to be installed.

I'm pretty sure what you're actually after is the server link, so yeah - that should do it.

  • 1
    Note: these links do not violate Mojangs TOS concerning redistribution, since they point to content hosted by Mojang themselves. mcversions.net has the links to a lot of different versions and server versions of MC. – MrLemon Aug 11 '14 at 10:58
2

Yes. Download the server software of whichever version of minecraft you require (let's say 1.6.4). In order for people to be able to play on it, they will need to change their version of minecraft. On the minecraft launcher, click edit profile in the bottom left corner. Then select 1.6.4 from the version drop-down menu and click save. Minecraft will then be 1.6.4 and you will be able to connect to the server. The drop-down menu allows you to select any version of minecraft, right down to the earliest alpha or beta versions of the game.

-1

First you have to know how to install mods then, in the bottom left corner of the launcher, click "edit profile" then a few lines down, there.should be a line with your current version on it click that. Then click the version you want.( if you want to go on the same server with the same mods/texture packs/etc. then all of the people you want to come have to have the same version) thx

  • 1
    This question is not about installing mods but about getting an older server.jar – MrLemon Aug 11 '14 at 10:55

Not the answer you're looking for? Browse other questions tagged or ask your own question.