10

I recently switched my whole system to Mac OSX (Snow Leopard 10.6) from Windows 7. Now I've installed WoW and imported my old configs/addons without any problems, besides that my keybindings from F1 to F7 are completely overriden by some Mac functions like brightness/sound/keyboard backlight etc.

How can I use my F-Keys in games?

  • 2
    I feel this question really belongs on Ask Different - it seems to have much more to do with Apple than with gaming. – Steve V. Aug 29 '12 at 2:34
  • The origin of my question was related to WoW only, because I thought this was WoW specific keybindings. But it turns out to be more general configuration, so my question was edited. Nevertheless I think it suits here quite well, when some is wondering why their keys in games doesn't work. – Rito Aug 29 '12 at 10:23
14

The option you want is in the Keyboard pane of your System Preferences:

Screenshot

Unfortunately this applies to all applications, not just WoW, which is kind of a pain because almost no other Mac OS X apps use the function keys for anything.

  • I'm sure there's a way to get quicksilver to turn that on and off with a few key-presses. – Ritwik Bose Mar 13 '11 at 18:39
  • You can try FNable (fnable.com). It will toggle this setting automatically based on the frontmost application. – Karsten Jul 26 '17 at 8:41
4

Use Option + Function-Key for the F1-F10 on Mac OS X.

  • It should be <kbd>Option</kbd>, not ALT. – CyberSkull Aug 21 '12 at 22:56
  • The option key has "alt" printed on it (on most recent Macs) – Steven Lu May 26 '13 at 2:03
1

For me it is fn + shift in Mac OS X v10.6.8.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.