I've just tried restarting my FTB world after not being able to get to The End.

I found and set up The End portal, but it just teleported me to a random location in the overworld every time. When I tried restarting the server, I got this crash log. Can anybody help me decypher this, and figure out what the issue is?

I've restarted my server with a new world, and that works fine, so I'm thinking it was something wrong with the old world, which I can hopefully fix in MCEdit.

2014-09-08 08:36:41 [INFO] Registered command hats with permission node 

2014-09-08 08:36:41 [INFO] Registered command morph with permission node morph.common.core.CommandMorph
2014-09-08 08:36:41 [INFO] Preparing level "SecondFTBWorld"
2014-09-08 08:36:41 [INFO] Registered command debug with permission node vanilla.command.debug
2014-09-08 08:36:41 [INFO] Registered command spreadplayers with permission node vanilla.command.spreadplayers
2014-09-08 08:36:41 [INFO] Registered command playsound with permission node vanilla.command.playsound
2014-09-08 08:36:41 [INFO] Registered command scoreboard with permission node vanilla.command.scoreboard
2014-09-08 08:36:41 [SEVERE] net.minecraft.util.ReportedException: Exception getting block type in world
2014-09-08 08:36:41 [SEVERE] at net.minecraft.world.World.func_72798_a(World.java:689)
2014-09-08 08:36:41 [SEVERE] at buildcraft.BuildCraftFactory$QuarryChunkloadCallback.ticketsLoaded(BuildCraftFactory.java:119)
2014-09-08 08:36:41 [SEVERE] at net.minecraftforge.common.ForgeChunkManager.loadWorld(ForgeChunkManager.java:514)
2014-09-08 08:36:41 [SEVERE] at net.minecraftforge.common.ForgeInternalHandler.onDimensionLoad(ForgeInternalHandler.java:64)
2014-09-08 08:36:41 [SEVERE] at net.minecraftforge.event.ASMEventHandler_1_ForgeInternalHandler_onDimensionLoad_Load.invoke(.dynamic)
2014-09-08 08:36:41 [SEVERE] at net.minecraftforge.event.ASMEventHandler.invoke(ASMEventHandler.java:39)
2014-09-08 08:36:41 [SEVERE] at net.minecraftforge.event.EventBus.post(EventBus.java:108)
2014-09-08 08:36:41 [SEVERE] at net.minecraft.server.MinecraftServer.func_71247_a(MinecraftServer.java:425)
2014-09-08 08:36:41 [SEVERE] at net.minecraft.server.dedicated.DedicatedServer.func_71197_b(DedicatedServer.java:224)
2014-09-08 08:36:41 [SEVERE] at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:630)
2014-09-08 08:36:41 [SEVERE] at net.minecraft.server.ThreadMinecraftServer.run(ThreadMinecraftServer.java:16)
2014-09-08 08:36:41 [SEVERE] Caused by: java.lang.NullPointerException
2014-09-08 08:36:41 [SEVERE] at codechicken.enderstorage.storage.item.TileEnderChest.reloadStorage(TileEnderChest.java:98)
2014-09-08 08:36:41 [SEVERE] at codechicken.enderstorage.common.TileFrequencyOwner.func_70312_q(TileFrequencyOwner.java:33)
2014-09-08 08:36:41 [SEVERE] at net.minecraft.world.chunk.Chunk.func_76604_a(Chunk.java:1102)
2014-09-08 08:36:41 [SEVERE] at net.minecraft.world.chunk.Chunk.func_76620_a(Chunk.java:1075)
2014-09-08 08:36:41 [SEVERE] at net.minecraft.world.chunk.storage.AnvilChunkLoader.loadEntities(AnvilChunkLoader.java:560)
2014-09-08 08:36:41 [SEVERE] at org.bukkit.craftbukkit.v1_6_R3.chunkio.ChunkIOProvider.callStage2(ChunkIOProvider.java:39)
2014-09-08 08:36:41 [SEVERE] at org.bukkit.craftbukkit.v1_6_R3.chunkio.ChunkIOProvider.callStage2(ChunkIOProvider.java:15)
2014-09-08 08:36:41 [SEVERE] at org.bukkit.craftbukkit.v1_6_R3.util.AsynchronousExecutor.skipQueue(AsynchronousExecutor.java:342)
2014-09-08 08:36:41 [SEVERE] at org.bukkit.craftbukkit.v1_6_R3.util.AsynchronousExecutor.getSkipQueue(AsynchronousExecutor.java:300)
2014-09-08 08:36:41 [SEVERE] at org.bukkit.craftbukkit.v1_6_R3.chunkio.ChunkIOExecutor.syncChunkLoad(ChunkIOExecutor.java:12)
2014-09-08 08:36:41 [SEVERE] at net.minecraft.world.gen.ChunkProviderServer.getChunkAt(ChunkProviderServer.java:189)
2014-09-08 08:36:41 [SEVERE] at net.minecraft.world.gen.ChunkProviderServer.func_73158_c(ChunkProviderServer.java:162)
2014-09-08 08:36:41 [SEVERE] at net.minecraft.world.gen.ChunkProviderServer.func_73154_d(ChunkProviderServer.java:285)
2014-09-08 08:36:41 [SEVERE] at net.minecraft.world.World.func_72964_e(World.java:804)
2014-09-08 08:36:41 [SEVERE] at net.minecraft.world.World.func_72798_a(World.java:680)
2014-09-08 08:36:41 [SEVERE] ... 10 more
2014-09-08 08:36:41 [SEVERE] Encountered an unexpected exception ReportedException
net.minecraft.util.ReportedException: Exception getting block type in world
at net.minecraft.world.World.func_72798_a(World.java:689)
at buildcraft.BuildCraftFactory$QuarryChunkloadCallback.ticketsLoaded(BuildCraftFactory.java:119)
at net.minecraftforge.common.ForgeChunkManager.loadWorld(ForgeChunkManager.java:514)
at net.minecraftforge.common.ForgeInternalHandler.onDimensionLoad(ForgeInternalHandler.java:64)
at net.minecraftforge.event.ASMEventHandler_1_ForgeInternalHandler_onDimensionLoad_Load.invoke(.dynamic)
at net.minecraftforge.event.ASMEventHandler.invoke(ASMEventHandler.java:39)
at net.minecraftforge.event.EventBus.post(EventBus.java:108)
at net.minecraft.server.MinecraftServer.func_71247_a(MinecraftServer.java:425)
at net.minecraft.server.dedicated.DedicatedServer.func_71197_b(DedicatedServer.java:224)
at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:630)
at net.minecraft.server.ThreadMinecraftServer.run(ThreadMinecraftServer.java:16)
Caused by: java.lang.NullPointerException
at codechicken.enderstorage.storage.item.TileEnderChest.reloadStorage(TileEnderChest.java:98)
at codechicken.enderstorage.common.TileFrequencyOwner.func_70312_q(TileFrequencyOwner.java:33)
at net.minecraft.world.chunk.Chunk.func_76604_a(Chunk.java:1102)
at net.minecraft.world.chunk.Chunk.func_76620_a(Chunk.java:1075)
at net.minecraft.world.chunk.storage.AnvilChunkLoader.loadEntities(AnvilChunkLoader.java:560)
at org.bukkit.craftbukkit.v1_6_R3.chunkio.ChunkIOProvider.callStage2(ChunkIOProvider.java:39)
at org.bukkit.craftbukkit.v1_6_R3.chunkio.ChunkIOProvider.callStage2(ChunkIOProvider.java:15)
at org.bukkit.craftbukkit.v1_6_R3.util.AsynchronousExecutor.skipQueue(AsynchronousExecutor.java:342)
at org.bukkit.craftbukkit.v1_6_R3.util.AsynchronousExecutor.getSkipQueue(AsynchronousExecutor.java:300)
at org.bukkit.craftbukkit.v1_6_R3.chunkio.ChunkIOExecutor.syncChunkLoad(ChunkIOExecutor.java:12)
at net.minecraft.world.gen.ChunkProviderServer.getChunkAt(ChunkProviderServer.java:189)
at net.minecraft.world.gen.ChunkProviderServer.func_73158_c(ChunkProviderServer.java:162)
at net.minecraft.world.gen.ChunkProviderServer.func_73154_d(ChunkProviderServer.java:285)
at net.minecraft.world.World.func_72964_e(World.java:804)
at net.minecraft.world.World.func_72798_a(World.java:680)
... 10 more
2014-09-08 08:36:42 [SEVERE] This crash report has been saved to: /home/Tom322/NN16310530/./crash-reports/crash-2014-09-08_08.36.42-server.txt

I believe the problem has something to do with the deep dark, as that's the only place I have a quarry, so first I removed the quarry with mcedit, that didn't help, so then I removed the whole DIM-100 folder, but that didn't help either

  • I think it might have something to do with some enderchest bugging out for some reason. Can you access the end on the new world? What specific pack +version are you using. (I can't check it out, because my PSU melted, but someone else might be able to)
    – Arperum
    Sep 8, 2014 at 8:15
  • Also: do you have enderchests in non-overworld dimensions? I remember that the server where I play on has an issue with having them in other dimensions (this is minecraft 1.7.2)
    – Arperum
    Sep 8, 2014 at 8:17
  • 1
    Yea, removing the mod will have replaced all blocks from said mod with airblocks. So now the offending tanks/chests is gone. I did forget to think about tanks. Also: if this solved your issue I'll make it into an answer tonight.
    – Arperum
    Sep 8, 2014 at 9:05
  • 1
    I'll report back later once I can try and login and let you know what the outcome is.
    – TMH
    Sep 8, 2014 at 9:09
  • 4
    I'm voting to close this question as off-topic because modded minecraft support is off topic here
    – Dragonrage
    Jun 26, 2019 at 18:43

2 Answers 2


This has occurred to me once. In my case, i have a quarry in the Deep Dark and whenever I start the server it would crash as it loads the chunk that causes such an error. From what I can gather, it appears to be a tile entity error with the ender chest. The reason that replacing the blocks with air may not work is that the corrupted tile entity is still there and attempts to load. The solution to solving this is as follows.

  1. Copy your server world to your client save folder.
  2. Load the world in single player and visit the affected area. This would cause the chunk to be force regenerated.
  3. Make sure you are back in the same dimension as when you have loaded in the first time. If you leave the game while in the deep dark in single player, it would result in a Not Overworld crash
  4. Copy the world back to your server and start the server.

This would remove the affected chunks and allow you to start the server. However this would result in a loss of whatever data in the chunk. Do take note to backup your world before attempting this. It is also noted that if the server updated since it first generated the world, the generation algorithm may have changed and result in different terrain in the corrupted chunk.

Addition: This is proven to work in a server. If it does not work, I would suggest clearing the world (DIM -100) as well as the EnderChests folder in all its entirety. I can confirm that the bug originates from the deep dark and how ender chests are placed there. I would recommend telling the users/yourself not to put ender chest and use tesseracts instead.

EDIT: I have just read the comments and noticed that you may have already solved the issue. If you have a backup of the world, i would suggest you attempt this method. It would allow you to recover everything but whatever is located in that chunk.

  • The OP tried removing the whole deep dark and that didn't fix it.
    – Arperum
    Sep 9, 2014 at 8:05
  • @Arperum It doesnt matter. The tile entity data is stored separately in its own folder. The folder is named EnderStorage located in the world folder.
    – DarkDestry
    Sep 9, 2014 at 9:30

The Solution that worked for me, was to remove the EnderStorage mod, restart my server (which loaded successfully then), then re-add the mod, and load up again.

I had to replace the Ender Tanks/Chests, but it worked. The issue seemed to be that Ender Chests/Tanks don't like being in none overworld dimensions.

Not the answer you're looking for? Browse other questions tagged .