I just bought a used PS3. The first thing I did was tried to connect it to the internet. However, it won't accept my WPA2 key.

So far I've tried increasing my clients available setting on my DHCP server, setting my wireless to G only, the age-old 'turn it off and on again' with both the console and router, and setting up a guest connection.

Nothing works- it just keeps saying the key infomation exchange timed out. Your wpa key may be wrong.

I'm sure it's not the WPA key- I've even tried specifically changing it to test this. I'm out of ideas. Can anyone help me with this?

  • 2
    @Schism SuperUser specifically forbids console questions. – Studoku Aug 20 '14 at 2:22
  • @Studoku hm. I could have sworn that I had seen them there before. Okay, close vote retracted. – Schism Aug 20 '14 at 2:49
  • StackExchange gaming isn't for console questions, rather questions about what goes on inside the games you run on them. This question is a more tech/hardware problem which doesn't go here (no mean girls pun intended). – SteppingHat Aug 20 '14 at 7:08
  • 5
    @SteppingHat Actually, questions on "game-specific hardware and utilities" like a PS3 are allowed on Arqade, so this is the right place to ask the question. See gaming.stackexchange.com/help/on-topic I also think there's no need to threaten new users with an account ban that doesn't even happen for asking an off-topic question (which this is not). – Kodama Aug 20 '14 at 7:46
  • Are you sure it is WPA2? And not some other WPA type? – DrakaSAN Aug 26 '14 at 8:42

I had the exact same issue as you and had the "Wireless Channel has interference" error. After changing the password multiple times I ended up calling my ISP and had them ship me a new modem and setup the router. Using the new SSID with the same username/pass (not that it matters I think) it connected to my PS3 successfully. Sucked, but it's working now.


Try changing your wifi password on your router control panel.

If this doesn't work try doing a factory reset.

If THAT doesn't work, try connecting to the console to a different network entirely at a friends place for example. This can either rule out wether your router/network is the issue or your console itself. From here it's a decider as to wether you need to get a new router or a new console.


Try changing the password on the router and seeing if you can now match it.

Ensure capitals and such like.

Other issues can sometimes be the Wireless Channel.

The router by default will often automatically search for interference and put the wifi on a channel. One of 1-16. Typically we see wifi on channels 1,6 and 11 but this really is down to you or the router.

It is common for the router to pick a channel that some devices read fine? But others at different ranges can see it? But the rate of transfer is almost negligible.

If the password is definitely correct maybe explore changing the wireless channel to see if that helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.