2

When I'm playing DotA, I can't see the following heroes/characters:

  • Shadow Demon
  • Warlock's Golem
  • Lucifer
  • Crystal Maiden
  • Yunero

If I turn on the shadow, I can see only the shadow. What's going on? How can I fix this?

Note: Version 1.26a (from 1.25b)

  • What have you tried so far? Have you downloaded the newest map and checked if that works? 6.81d fixed a few more bugs so it might be the case with your bug. DL Link .Have you tried reinstalling Warcraft III already? Did you check if the map is corrupt? Did this problem occur after you downloaded the new map or when? – Wandang Aug 24 '14 at 13:51
  • I tried switching back to old version using version switcher. Still no change. I tried also different map from different sites, still no luck. – Ulfric Stormcloak Aug 24 '14 at 16:48
  • 1
    So even in older dota versions like 6.80 you get this bug? Then it is clearly a bug in wc3 (or your pc) rather than in the mapfile itself. Did you already update your graphic driver? I still would recommend just reinstalling warcraft. That's what I did back in the days if something wasnt working in wc/dota. PS: You should NOT downgrade the wc3 version because the dotamap uses the newest mapeditor entities/etc. Always take the newest version – Wandang Aug 24 '14 at 20:08
  • All my drivers are correctly installed. And by the way, I'm no average computer user. I am an IT/programmer by profession. So I tried everything to troubleshoot the prob. May be the model for those characters are not loaded or something. Lastly, my system can play Watch Dogs in ultra mode graphics so I think there is no issue regarding my PC specs. – Ulfric Stormcloak Aug 25 '14 at 8:54
  • I just want to know if someone encountered the same problem and found a solution. – Ulfric Stormcloak Aug 25 '14 at 8:56
3

It seems like there are still some textures missing from the game.

Before you try anything else, attempt to run WarCraft III in OpenGl mode.

If the problem persists:

  1. Repair or reinstall WarCraft III and The Frozen Throne
  2. Update to the newest version
1
+150

From what you said in comment, you "installed" WIII from a backup of your old PC. Windows, sadly, doesn t work like that, and a lot of thing (register for example) might be missing and end up bugging your game by missing textures.

It could also be a simple DRM, setup set a value in the register, needed to decrypt the model. Since you copied the model but don t have the key, the game ignore the model altogether.

What you should do is find your CD, reinstall from it, or if the CD is unusable but you still have a valid CD-key, go on battlenet, and download WIII/Frozen Throne from there and install properly.

If you don t have your CD(-key) anymore, try to find a friend who still have it, or buy one (I find it regulary for 10€ at video games stores, battlenet price seems to be $15).

EDIT:

I ll add that a key for WIII alone seems to give WIII and Frozen throne in battlenet, but I d like confirmation.

  • that is what i was saying...reinstall. not recopy ;) but thanks for pointing that out – DropDeadSander - EUW Aug 29 '14 at 9:39
  • since you gave this answer the bounty. did it solve your problem? – DropDeadSander - EUW Sep 1 '14 at 7:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.