2

Whilst playing Fallout 3 with mods my game appears to crash more then it normally would do, I have checked to see that they are not conflicting mods to make sure that is not the cause of the problem and have come to the conclusion that the game is not allocating itself enough RAM(I think its about 2Gb its allocating).

My question is, is there a way in which I could allocate more RAM to Fallout 3 to hopefully make the game more stable.

Im running Windows 7 64bit with 16Gb of RAM if that is any help.

  • Are there any error messages for the game crashes in the event log? – Michael K Aug 21 '14 at 9:27
3

I would use a mod to change the program, Fallout 3 was made specifically for 32bit and so can only utilise 2GB of ram.

Nowadays newer games have "Large Address aware" set up so that they can access more memory, Download this mod and follow the instructions below and it will assign the game more memory without worrying about changing windows settings.

Make Fallout 3 Large Address Aware using this utility:

  • Make a back up copy of Fallout3.exe.
  • Put Fallout3.exe in the '3GB enabler' folder
  • Double click START.BAT
  • Follow the instructions in the command window
  • Once made Large Address Aware, return the fallout3.exe to your game folder.

If you are using a 64 Bit operating system (XP, Vista, Windows 7/8/8.1), you are Done!

Then you must restart your computer for this to take effect

  • You can skip the restart part. No computer needs a restart just because you change a flag in a binary ;). However, using this can make the game unstable. – user28015 Aug 21 '14 at 13:35
  • 2
    @NoneOfYourBusiness I have never had my game become unstable from this, and i do this everytime i install the game – Flaunting Aug 21 '14 at 13:44
  • Hence the "can" – user28015 Aug 21 '14 at 14:20
-2

Edit: I'm wrong, this only helps (rarely) for 64bit applications. Ignore this advice regarding Fallout 3.

Try increasing the size of the pagefile and see if it helps.

https://www.microsoft.com/resources/documentation/windows/xp/all/proddocs/en-us/sysdm_advancd_perform_change_vmpagefile.mspx?mfr=true

From this article:

  1. Open System in Control Panel.

  2. On the Advanced tab, under Performance, click Settings.

  3. On the Advanced tab, under Virtual memory, click Change.

  4. Under Drive [Volume Label], click the drive that contains the paging file you want to change.

  5. Under Paging file size for selected drive, click Custom size, and type a new paging file size in megabytes in the Initial size (MB) or Maximum size (MB) box, and then click Set.

If you decrease the size of either the initial or maximum page file settings, you must restart your computer to see the effects of those changes. Increases typically do not require a restart.


Usually this is managed by the OS itself, and correctly, but maybe this is still helpful.

  • What is this supposed to do? @Elliot said that the game is only taking up a small amount of his RAM, thus there is no paging involved here. Fallout 3 is a 32bit program, therefore it is not able to take up more then 3,6GB of his 16GB RAM anyway. – Michael K Aug 21 '14 at 9:25
  • @MichaelK Its more than that, as 32bit programs can only take up a max of 2gb so that it doesnt take up all the memory – Flaunting Aug 21 '14 at 9:29
  • @MichaelK My bad, I didn't realise Fallout 3 was 32bit only. This obviously only does something for memory-hungry 64bit applications. – No. 7892142 Aug 21 '14 at 9:30
  • @Flaunting, it technically could take up to 3,6, provided that it uses LAA. – Michael K Aug 21 '14 at 9:31
  • @No.7892142 Almost all games are 32bit only. Even the few that support 64bit would not fill up 16GB of RAM. – Michael K Aug 21 '14 at 9:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.