5

Whenever I start a game, from both the disc and hard drive, my Xbox will say "Username signed out". What's wrong and how do I fix it? Just to be clear, it signs me out when I start a game. How can I stop this?

  • Does it happen only if you start Terraria or Halo Reach? If not, you should remove those tags from your question – Nolonar Sep 7 '14 at 19:20
  • @Nolonar I edit my question. – Jonco98 Sep 7 '14 at 19:33
  • Does it prompt you to download updates? – TZHX Sep 7 '14 at 19:45
  • @TZHX No, prompts, but it does say something about NAT. – Jonco98 Sep 13 '14 at 1:42
8

It sounds like you've refused an Xbox Live Update at some point.

You can go into your system options and see if there's an update available.

To check for an update on the Xbox 360 you basically force a new Xbox Live connection:

  1. Press the Guide button (center logo button), bringing up the pop-up menu
  2. Go to Settings
  3. Select System Settings
  4. Select Network Settings
  5. Select Wired Network or the name of your wireless network if you're on wifi
  6. Select Test Xbox Live Connection
  7. Select Yes if prompted to update. If you're not prompted and the test completes successfully, you have the most recent update.

You can also get console updates on the 360 through game discs with them, USB drives, or CDs and DVDs burned with the updates, but the above instructions are by far the easiest and should apply to most cases.


To check for an update on the Xbox One (since it has the same problem):

  1. Go to the Home screen
  2. Press the Menu button (where the "start" button is on other systems)
  3. Select "Settings" from the popup menu
  4. Select "System"
  5. Select the update option if it's available. It will say "No update available" if you're offline or you have the newest update.

Source: The xbox support system and personal experience

  • Just for the sake of the answer, please explain how to check for an update. – Jonco98 Sep 8 '14 at 10:34
  • Ok, this worked for THAT day, now it's happening with any game I start to play. – Jonco98 Sep 13 '14 at 1:14
  • 1
    I think there was another update... do you have your system set to auto-accept updates? If not you'll have to manually re-update when there's a new one. – Eben Sep 13 '14 at 8:39
1

After doing some research I found a solution.
1. Delete your profile.
(Settings >> System Settings >> Storage >> Hard Drive >> Profiles >> username >> Delete >> Profile only)
2. Clear you System Cache 3 times.
(Settings >> System Settings >> Storage >> Highlight Hard Drive >> Press Y >> Clear System Cache >> Yes)
3. Re-download your profile.
(Press Xbox Guide Button >> Download Profile >> Enter your Microsoft E-Mail >> Enter your Microsoft Password >> Done)
See Taidara's Answer For More Information.

  • I don't get this, this user said in the comments of an answer above that the solution worked, but there's also an answer here by that same user. – Jim Jones May 7 '16 at 5:13
  • @JimJones They then later said "Ok, this worked for THAT day, now it's happening with any game I start to play." So this must have fixed it for good. – DCShannon May 7 '16 at 5:17
1

After it signs me out the first time, I just go straight to download profile. Then I select my profile without having to delete it first. Problem is that once you shut off the power to your console it may or may not start over again the next time you power it back on . The last time I went through 10 days of powering on and off before the issue returned.

protected by Frank Jan 27 '15 at 23:10

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.