This has happened several times, but I've just realized that this weird "Oops sorry!" message seems to be causing it.

Here is the most recent case I'm facing with Hawken. I tried adding the game to my Wishlist, but failed. It displayed the message "Oops sorry!" for a moment. I refreshed the page, and the button disappeared.

enter image description here

I checked my Wishlist page, just in case it's been there. But unfortunately the game has not been added to my Wishlist either.

This has happened several times and it's quite annoying.

Anyone can help me?

enter image description here

  • Are you using the client, or the web? Have you tried restarting Steam? You can probably do it via the web, as a temporary workaround.
    – ver
    Sep 18, 2014 at 20:40
  • 4
    Why do you want to add a free to play game to your wishlist? It's already as on sale as it's going to be. Is this occurring with other games?
    – Unionhawk
    Sep 18, 2014 at 20:44
  • Does this happen with all games or just this one?
    – aman207
    Sep 18, 2014 at 20:45
  • 3
    If you own the game you cannot add it anymore...
    – Gerret
    Sep 18, 2014 at 21:09
  • @Gerret I haven't own the game. It says "You already own Hawken" because it's a free to play game.
    – deathlock
    Sep 18, 2014 at 22:41

1 Answer 1


The problem might be that the game you picked is free to play. It doesn't need to be bought, so there is little reason to add it to your wish list.

However, a more useful error message would definitely be in order. You might want to report this as a bug to Valve.

  • Yeah, the only reason I added it to my wishlist is because I tend to forget a lot. So my wishlist serves as my personal reminder. I'd love to report this as a bug, do you know the link?
    – deathlock
    Sep 23, 2014 at 7:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .