7

Every time i start the game and join a server i get these annoying pop-up hints that won't leave until i have done what they want me to do, (zoom in with a scope, press 'e' to look at the gun). So right now what i do is join a random server, do all the common things they tell me to and then join a proper competition server to play. Is there a command line i can add to my configuration file to get rid of them ?

13

Go to the options in CounterStrike : GO and disable the Game Instructor Messages as seen in this screenshot:

Game Instructor Screenshot

This should stop the game from annoying you in the future.

Another method would be to open config.cfg in your CS GO Folder (after you removed the mentioned read-only flag) with a text editor of your choice, such as Notepad++. You can find the file in X:\Steam\SteamApps\common\Counter-Strike Global Offensive\csgo\cfg (X being the hard drive you installed it on). Then find the line where it says gameinstructor_enable and set it to 0 or, if it is not there, add gameinstructor_enable=0 at the bottom of the file. That should do the trick.

  • but the problem is that my config erases this parameter every time i restart the game ! isn't there a command line in my config associated to that ? – user3714670 Sep 21 '14 at 11:45
  • Your config cannot erase this option. Edit your config file into your OP if there is a problem with it and be more specific. – user28015 Sep 21 '14 at 12:04
  • my config file is read only so when i change the in game settings, it cannot write them in my file. – user3714670 Sep 21 '14 at 14:25
  • @user3714670 I updated my answer – user28015 Sep 21 '14 at 16:28
3

It is now: This PC/Windows C/ windows (86x)/Steam/userdata/(OWN ID SHOULD BE ONE FOLDER)/730/local/cfg

Go through the config file and check if you don't have any binds to enable gameinstructor. (That was my problem I got so frustrated; my buddies just did bind mouse1 "attack;gameinstructor_enable" or something).

  • Your friends might be geniuses. That is a sweet prank due to both how harmless it is and how annoying that problem would be. – JMac Feb 16 '17 at 20:20
0

You can also enter

gameinstructor_enable 0 

in the developer console.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.