4

The title does explain my question quite well, but here is some more details about the option itself. The -novid launch option for Dota2 can be set through the Steam Library page. It disables Valve's intro (The guy with the valve at the back of his head) before starting dota.

Here is a picture of my launch options:

Screenshot of launch options

6
  • Show us a screenshot of your launch parameters please. I have a hunch.
    – user28015
    Sep 26, 2014 at 5:33
  • Sure, here is a image puu.sh/bOhz1/20862e7c8f.png although you can't see all the parameters you can see the -novid. Here is the full thing: (-console-novid-noaafonts-high-noforcemaccel -noforcemspd -useforcedmparms) And thank you for responding!
    – user271360
    Sep 26, 2014 at 5:50
  • My hunch was right :P
    – user28015
    Sep 26, 2014 at 6:25
  • After I finish downloading an update, will check to see if it worked. If it does, good sir. You will earn a completed question (if that is how you say it) (and a +1 if I have enough rep for that..). Thanks in advance!
    – user271360
    Sep 26, 2014 at 10:27
  • A thing to note about using -novid: It will actually make your minimap in game display at a lower resolution than it should. As far as I know, there is no fix for this at the moment. Oct 9, 2014 at 19:12

1 Answer 1

8

You need to put a space between every launch parameter, otherwise it won't work.

Like this:

-console -novid -noaafonts -high -noforcemaccel -noforcemspd -useforcedmparms

The reason is, that the operating system only treats each parameter separately when separated by spaces. Then it puts the count of the parameters into a variable, known in Programming as argc, while the parameters reside in argv. So without a space, Dota 2 (respectively the Source Engine) would only receive 1 parameter at all and not recognize any of them, because they do not match any option.

1
  • Thank you! If worked! I can't +1 you because I would need 15 points of rep, but at-least can have a small one here : +1
    – user271360
    Sep 26, 2014 at 10:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .