2

When you answer this question please keep in mind that I am a mom trying to help her 7 yr old son to do this. I have no working knowledge of Minecraft software or of Linux so just when you think you've stated something as simply as possible dumb it down just a little more. Please take me from beginning to end and provide any links that you possibly can for downloads etc. I appreciate that this will likely be a long and time consuming answer. Please know how appreciated it will be by both of us. He is running Minecraft 1.8.

Specifically:

  1. Should I be installing Forge before installing the Star Wars mod? If so, does anyone have a trusted link for Forge.

  2. Can you still play regular Minecraft with the mod installed and if so, how does that work?

  3. The instructions I'm finding for the Star Wars mod are not specifying what OS they are for. Is there anything I should know to change since we are running Linux?

  4. Does anyone have a trusted link to download the Star Wars mod that will run on Minecraft 1.8?

  • 2
    While I appreciate that you need help, unfortunately Arqade doesn't work very well for general guides on how to do things. We work better if you try to follow the instructions the mod hopefully gives you, and if you get stuck, ask about that part. I believe this question may be able to help you for some questions and perhaps get you started. – Frank Oct 3 '14 at 3:18
  • I should have said this before but I have googled on how to do this and keep coming up with out of date and conflicting information not to mention the random porn sites I've been sent to through links. I am concerned that I am going to end up making matters worse through my lacked knowing what I am doing but here goes on an attempt to ask more specific questions. – RookieMom Oct 3 '14 at 14:25
  • #1. Should I be installing Forge before installing the Star Wars mod? If so, does anyone have a trusted link for Forge. – RookieMom Oct 3 '14 at 14:46
  • #2. Can you still play regular Minecraft with the mod installed and if so, how does that work? – RookieMom Oct 3 '14 at 14:47
  • #3. The instructions I'm finding for the Star Wars mod are not specifying what OS they are for. Is there anything I should know to change since we are running Linux? – RookieMom Oct 3 '14 at 14:49
8

Answering your questions in the comments:

  1. Should I be installing Forge before installing the Star Wars mod? If so, does anyone have a trusted link for Forge?
    Forge is a required API in order to run the "Star Wars" mod as without it, the mod will fail to work as Forge contains functions and methods that are not included with Minecraft.
    As for a link to the forge downloads - http://files.minecraftforge.net/minecraftforge/. The one you're probabally be looking for is this one. Just download and run the application and follow the prompts
  2. Can you still play regular Minecraft with the mod installed and if so, how does that work?
    Yes, you can play regular Minecraft with the mod installed. If you attempt to connect to a server that does not have the mod installed, it will automatically deactivate (items are loaded into memory, but cannot be used, crafted, obtained in any way, etc.; basically restricted to vanilla items, or any item from mods that are installed on the server too)
    However, if another player tries to join onto a Single-Player world (over LAN) without the mod, he/she will be kicked by the player's client-server as players without the particular mod wouldn't be able to see the items as to their game "it does not exist".
  3. The instructions I'm finding for the Star Wars mod are not specifying what OS they are for. Is there anything I should know to change since we are running Linux?
    The mod installation does not matter for the operating system. You only need to know how to decompile/recompile a .jar (I meant compress/decompress a .zip file) and knowing where to drag the files.
  4. Does anyone have a trusted link to download the Star Wars mod that will run on Minecraft 1.8?
    TL;DR - There isn't one.
    Why? The mod's creator has not updated his mod to support 1.8, along with the fact that the API that is required to run the mod has not updated to 1.8 yet either. 1.7.10 is the highest version that Minecraft Forge supports.
    As for using the mod on 1.7.10? Also not possible, as Forge versions vary in codebase; so anything written for a particular version of forge can only function with forge for the same version of Minecraft. Any higher or lower (does not matter if it's a major (ie. 1.8 and 1.7) or minor (ie. 1.2.2 and 1.2.5) release/update).

Note: I don't have any computer running Linux, so apologies if everything is incorrect and for the lack of pictures. I'm answering based on sources on the internet (ie. the wiki)

A small note:
About getting ads and links to pornography sites - It is because you are clicking on the wrong links! When you are linked to the downloads, you were sent through ad.fly; an internet link shortening service that shows an ad before linking you to [whatever page it is linking to].

When you open the page, you see something like this: An example of an ad.fly page Note: The actual ad varies.

All you have to do is click the big "Skip Ad" button at the top. Do not click on anything else on the page, even if it asks you to. If there isn't a "Skip Ad" button on the top, it means you have to wait a few more seconds before it appears.
Depending on which ad you get, you may be redirected to pornography sites, or to download adware/viruses*.
Do not click on any "Click here to download" links either. Those links do not bring you to your intended destination. (MegaCo. (the 'new' MegaUpload), for example in this ad/picture does host Minecraft mod files, however neither Forge or the Star Wars mod use it. Forge is hosted on its own site while the Star Wars mod is on MediaFire)
* It is against Adf.ly's advertiser policy to link (does not matter if it is an advertistment or shortened link) to malware/viruses or pirishing sites anyway. Adware on the other hand do not count as viruses as swarm your computer with advertisements and not take over/control/hijack/spy on/steal from it etc.

On the MediaFire website (the one to download the Star Wars mod), DO NOT click on anything else other than the big green button with "DOWNLOAD (28.47MB)".
Just be prepared to close a pop-up window that it creates, and it will fill the whole screen while opened.

How to install the mods
Warning: These instructions are for Linux computers, running Ubuntu!

  1. Download the files.
    Links: http://files.minecraftforge.net/maven/net/minecraftforge/forge/1.7.2-10.12.2.1121/forge-1.7.2-10.12.2.1121-installer.jar and http://www.mediafire.com/download/49o0ecegm9k4fx3/StarWars_mod_1.1.5f.jar

  2. Run the 1.7.2-10.12.2.1121-installer.jar and follow the on-screen prompts.
    Note: Because you're installing Forge onto the game, select the "Client" installation.

  3. Drag the StarWars_mod_1.1.5f.jar into the .minecraft/mods/... folder.
    It can be found in home/[your username]/.minecraft/mods/...
    Because a folder with a '.' is a hidden folder, you'll need to press Ctrl-H in Nautilus to show hidden folders.
    Just copy StarWars_mod_1.1.5f.jar into that folder. Do not decompile (extract/decompress) it.

  4. Open the Minecraft launcher. Change your profile (drop-down menu on the bottom left) to "Forge" and click "Play!".


I hope this helps and remember - Stay safe on the internet and don't click on advertising... Unless you're actually going to buy [the product the ad is advertising].

| improve this answer | |
-1

One easy answer: There's a modpack launcher called Technic Launcher.

After you download it, you only have to click the "Install Star Wars" button in it.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.