1

In all versions of Minecraft with Forge (I tried with 1.7.10, 1.7.2 and 1.6.4) I am perfectly capable of launching Vanilla Minecraft from the launcher, when I attempt to launch it with Forge, the process simply stops, no crash, or anything of the sort. The launcher closes itself, there is no error message, it simply stops the process. The launcher doesn't reopen. How do I get it to run properly?

closed as unclear what you're asking by MrLemon, TZHX, Frank, Studoku, Shadow Z. Mar 27 '15 at 16:26

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • You can find your error logs in %AppData%/Roaming/.minecraft/logs/... Also, you may want to take a look at this meta.gaming.stackexchange.com/questions/9943/… and edit your question to fit it. – aytimothy Oct 11 '14 at 19:25
  • 1
    I'm voting to close this question as off-topic because it is tech support for modded Minecraft. We only provide tech support for vanilla Minecraft – Jim Jones Jan 18 '16 at 4:01
2

Down/upgrade your java to 1.7. Forge doesn't seem to support java 1.8 (yet)...

  • When installing Java 1.8, it has an option for not uninstalling Java 1.7. If you accidentally did not uncheck this option. You can still download Java manually (oracle.com/technetwork/java/javase/downloads/…). Unpack the tar.gz and copy the content to fit the path indicated in "minecraftdad" answer. – Tormod Apr 19 '15 at 12:23
1

The problem is that a new load of minecraft will still load the 8.1 version of Java it downloads into the 'program files(x86)\minecraft\Java' directory. Forge defaults to this. I had the same problem and deleted and reloaded everything. Same problem. Forge dies after you click "play"

What you need to do is under edit profile. click use other Java settings Advanced and give it the path to the Java 7 bin file. Mine was "c:\Program Files(x86)\Java\jre7\bin\javaw.exe"

Worked first time after that and no problems since.

  • Yeah, Minecraft has been having BIG issues with Java 8 for quite a while now. Either Java 6 or 7 work great. – user92092 Dec 30 '14 at 6:15
  • The java 8 installer prompts to uninstall old java versions (like the java 7 you have installed.). Only if you would skip that option in the installer, that would work. – nelson2tm Mar 30 '15 at 16:53

Not the answer you're looking for? Browse other questions tagged or ask your own question.