3

I'm playing Garrys Mod, Multiplayer on LAN and for whatever reason, tools aren't working. I can't find any setting to turn them on, either. And, when I say "not working," I mean that their groups are showing up in the spawn menu, but there is nothing to select.

7
  • Do the default "tools" and weapons show up? If they do can you use them properly?
    – tgrosinger
    Commented Mar 22, 2011 at 2:53
  • @ursa_arcadius: The default weapons work. But there are no tools to select/use. Commented Mar 22, 2011 at 3:00
  • Can you use the physics gun as one of the default weapons? Also, are there any settings that would disable using any tools in multiplayer? I could see there being an option if you wanted to keep people from griefing on your server (although doing so would make little sense in LAN).
    – Sadly Not
    Commented Mar 22, 2011 at 3:38
  • @SadlyNot: Yes, the physics gun is one of the default weapons and I can use it. I don't know of any setting to turn off tools. Commented Mar 22, 2011 at 12:58
  • I would guess that the server has certain tools disabled.
    – Jason_c_o
    Commented Oct 26, 2011 at 19:27

1 Answer 1

1

You're probably missing a some Lua files, to fix this I suggest one of a few things.

  1. Use Steam to verify the install by right clicking the game and going to Properties -> Local Files -> Validate Integrity Of Game Files

    • Or if you're running a server: steamcmd.exe +login anonymous +app_update 4020 validate +quit
  2. Run the FactoryReset-GMod.bat file in the root GarrysMod folder

  3. Manually verify / download the files from the Garry's Mod Github and replace old ones. (I Advice against this as the files are development level and may not be fully tested.)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .