6

Can anyone tell me why Fallout 3 GOTY edition keeps freezing after playing a certain time? Already updated the video card driver. Windows updated. Using Windows XP. Display card is ATI HDI48XX series. Already in windowed mode, no vertical sync, chose medium graphic details.

Thanks.

2
  • Do you have a multi core machine with more than 2 cores?
    – Frank
    Mar 23, 2011 at 11:30
  • Just FYI, the game is buggy and freezes alot...
    – Andy
    Jun 12, 2011 at 18:33

3 Answers 3

7

There seems to be a problem with multi core processors and a suggested fix can be found here. Although it states to be for Win7 I heard it work for other windows versions as well.

The game engine has some issues with processors that have more than 2 cores. You can force the game to only use two of them and it will stop the freezing. I haven't had it freeze once since I did this several days ago.
Open up the fallout.ini file in: My Documents\My Games\Fallout3
Find the line:
bUseThreadedAI=0
change it to:
bUseThreadedAI=1
Add another line after it and insert:
iNumHWThreads=2
This will limit the game to 2 cores and prevent the engine bug from causing the game to freeze.

Not sure if it's gonna solve your problem, but you might want to give it a try as it's simple to test out (and to reverse the changes if it's not helping).

3
  • 4
    I found out that is not the fallout_default.ini in the fallout 3 installation folder, it is talking about something like C:\Documents and Settings\user\My Documents\My Games\Fallout3, and there is a fallout.ini, change that, it really work, thanks! Mar 25, 2011 at 15:43
  • Yep. Worked for me too. Also there is a very good unofficial bugfix patch available. Since applying both of those, I not crashed except when a cat walked on my keyboard and somehow launched Games For Windows Live which has such a horrible interface I couldn't escape it and had to shut down.
    – Dronz
    Jun 12, 2015 at 3:14
  • Works on Windows 10 too. Also, the bug only seems to affect Fallout 3, not New Vegas.
    – Nolonar
    Oct 31, 2015 at 19:40
1

For non-Steam versions of the game, make sure you have it patched to the latest version, which you can get here

If that doesn't work, I highly recommend this Tweak guide it helped me when I couldn't get it to work on 8.1 but it will work for other OS's. The biggest problem the game has is the multi core one but it might also help to open the .ini file and enable the hard drive cache.

Also (believe it or not) the sound in the game can crash it try to double the sound cache if your system can handle it.

2
  • Welcome to Arqade! This looks like a pretty decent answer to this question, but the question is 3 years old with an accepted answer. There is nothing wrong about answering a question this old, but it is much less likely to be noticed.
    – ken.ganong
    Jan 14, 2015 at 21:24
  • @ken.ganong - We don't have a problem with bumping old questions with new content, in fact we prefer that questions/answers get updated and added rather than new questions asked. Tristian's answer covers non-steam versions of Fallout 3 (Steam's version is kept up to date automatically). The only thing Tristan - if you could summarise the information in the tweakguides here that'd be great. We prefer to do this in case the link ever goes bad, that way your answer will still be useful :)
    – Robotnik
    Jan 15, 2015 at 5:26
0

In case someone comes across this more recently, this is a well known problem and the primary fix including other performance remedies can be found in this Gopher video:

Modding Fallout 3 - Part 4 : Performance & Stability (BASIC)

However, in my experience if you want a 100% stable game you use the Tail of Two Wastelands mod to import Fallout 3 into the New Vegas engine and mod it for stability. There are simply more things you can do including using NVAC - New Vegas Anti Crash.

Currently have put ~143 hours into a play though and I might have had one or two crashes? Regardless I can't remember the last time I did have a CTD. The only problem I have ran into is after about 6 or 7 hours the game gets slower and starts to chug in which case you just restart it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .