1

Bukkit is not available at the moment and I searched for other server software that supports plugins. Glowstone supports the Bukkit API, so I am able to use Bukkit plugins.

But I have a problem with the world generator. I do not even think such a biome exists... As you can see the sand is fading to the grass.

Screenshot

The new generated maps always starts with rain and thunder. What do I have to do to get this working?

System Information

  • Glowstone: 1.8-84-gd5a1f56-b86
  • Java: 1.7.0_67
  • Client: 1.8
  • OS: Windows 8.1
  • Arch: amd64

Plugins

  • WorldEdit: 6.0.0
  • VoxelSniper: 5.170.0

I also tried it without plugins!

Configuration File

# glowstone.yml is the main configuration file for a Glowstone server
# It contains everything from server.properties and bukkit.yml in a
# normal CraftBukkit installation.
#
# For help, join us on IRC: #glowstone @ esper.net

server:
    port: 25565
    name: Glowstone Server
    online-mode: true
    max-players: 20
    whitelisted: false
    motd: Glowstone Server
    shutdown-message: Server shutting down

folders:
    plugins: plugins
    update: update
    worlds: worlds

world:
    name: world
    spawn-radius: 16
    view-distance: 8
    gen-structures: false
    allow-nether: false
    allow-end: false
  • This is a very specific problem isolated to an attempt to go beyond the boundaries of what is supported by the mods. You shouldn't expect things to work at all when you rely on mods to work together before a working alpha-release. "Glowstone supports the Bukkit API" doesn't mean they perfectly re-create Bukkit, and even less so beyond any released version of bukkit. I advise patience. Wait for a release of official Bukkit and don't try to use a glowstone semi-port of it. – Luke Oct 17 '14 at 17:30
0

Go to singleplayer, create a world, name the world (folder) world and generate it. After that exit the world and copy the folder to your server.

  • Did you even tried that out? It is not working! The server is generating a cliff and the old biome is generated. Furthermore it constantly throws exceptions because there is a argument error in a chunk! – Gerret Oct 17 '14 at 17:26
  • I don't know any other solutions... Sorry :( – nelson2tm Oct 17 '14 at 18:22
0

This is not a problem of your set-up! The world generator is not finished yet and only generates this biome...

On the issue site you find this from a developer.

World generation is fairly bleh right now and does not feature biomes. It also does not use the updated generation API. The optimal solution to rectify this would be:

Adapting world generation from Spout vanilla to either:
    a) Include in core as the default world gen.
    b) Distribute as official plugin, with an extremely minimal flatlands core gen.

Alternate options that were considered:

(In plugin form ONLY - not core) Somehow linking with vanilla jar to get accurate terrain gen.
Creating new world generation by regular contributor.
Asking around for an existing Bukkit generator to include.

The generator should reasonably approximate the vanilla generator in terms of biome diversity and characteristics, and should not have obvious flaws.

So you just have to wait a bit till this world generator is finished.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.