I Just installed TrackMania nation forever on my new laptop without any error (steam).
But when i enter a race, the textures iín the car and the apexes are low res and blurry.
I have set the quality to MAX, and updating the game with a update patch did not fix it either.

  • no one has a fix for this? Oct 16, 2014 at 9:31

4 Answers 4


In accordance with the advice in this post on the TrackMania forum: (this post was for United but works with Nations too)

1 - Edit C:\Program Files (x86)\Steam\steamapps\common\TrackMania Nations\Nadeo.ini

2 - Change delete what is after "Distro=" and make it "Distro=MILIN"

3 - Download http://files2.trackmaniaforever.com/TmNationsForever_Update_2010-03-15_Setup.exe

4 - Install the patch and point it to C:\Program Files (x86)\Steam\steamapps\common\TrackMania Nations

5 - Run Trackmania, from Steam or the folder itself.

  • i have changed the Distro, but it says "Distro not compatible Oct 16, 2014 at 12:00
  • does not work for me Oct 26, 2014 at 20:52

If the above does not work for you, then try this after making the changes above

Go to Configure > Advanced > Compatibility, and slide the AGP usage up to 100% > save changes. Notice that even though you might have a PCI-E card, still slide the AGP usage to 100%. I have seen people reporting positive feedback on Steam after this.

  • i will try that, when i get my computer back. Oct 30, 2014 at 17:06
  • Any update on this ? Nov 14, 2014 at 7:11
  • still havnt got my computer back :( stupid Lenovo Nov 30, 2014 at 18:48


Had this problem on my new MSI laptop with a GTX850M and was about to give up when I decided I would try and copy the configs from my desktop over to the laptop and see if it fixed it... AND IT DID! So if you have another PC that it runs fine on find your "Default.SystemConfig.Gbx" file (which is under Documents\TrackMania) on that PC and copy it over to the one running low res.

Note: I installed the game and ran it once before copying the file over. This was to ensure it would not run that bench test on first run and overwrite my copied file. Good luck cause I'm not sure if it will work for you but it sure did for me. And remember that you probably don't want to run the before games settings and overwrite that file so just leave it alone. In game graphics changes seem to be fine though. Enjoy!


So, i experimented like every single option, and turns out the problem is the anti alialiasing. It's the first option under the costumize check box. If you turn that to none, it will be good. Have no idea why tho

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .