2

A while ago my Minecraft started to flicker. The screen flashes once in a while when I move around. It doesn't when I stay still, just when there is movement. Any help? I would try to take a screen shot but it's really hard to catch, happens really randomly and rapid. When in survival the creative menu flashes instead of just a white flash. This is in singleplayer.

Edit: tried deleting and re-installing Minecraft. Also tried other versions of the game through the launcher. Still flickers... Drivers are fully up to date

This is on a razor laptop with NVIDIA 765 and Intel i7

  • 2
    Are you using any texture packs? what graphical settings are you using? – Ben Oct 15 '14 at 22:40
  • 2
    Turning vsync on might help – CJStuart Oct 15 '14 at 22:41
  • 1
    Are your drivers up-to-date? – TheBird956 Oct 15 '14 at 23:38
  • 1
    I've seen weird rendering issues over 6 chunk render distance on 1.8 if you use the default of 1GB of ram. If you have 64-bit computer/Java, you can try bumping up the amount of ram assigned to Minecraft and see if it helps. – mellamokb Oct 16 '14 at 21:14
  • 2
    I haven't played Minecraft in a while so I don't know if this would work, but have you tried installing OptiFine. I'm not sure what kind of effect it would have, but considering you've uninstalled and reinstalled, it might be worth a try. – Rob Rose Nov 22 '14 at 2:37

15 Answers 15

4

This is probably a performance issue.

First of all, try different video settings. Such as turning Fancy to Fast if it's on, no smooth lighting and render distance to minimal chunks. Just try scrolling through them and see what the effect is on your performance.

If that does not help, check your ram allocation using F3, and look in the upper-right corner of the screen. If that gets above around 70-80 %, (depending on preference) add more ram to Minecraft. (Remember you need to make sure other programs can still run without Minecraft consuming all the ram so that might be a problem)

You can do this in the profile editor under Java settings (advanced). In JVM Arguments you will see that you can input how much ram you want Minecraft to be running on. In this box you fill in:

"-Xmx2048M -Xms2048M" for 2GB ram

"-Xmx4096M -Xms4096M" for 4GB ram

To add more, add 1024 to the numbers for an extra gigabyte.

eg, 4096 (4GB) + 1024 = 5120 (5GB)

If that does not help, try deleting your .minecraft folder in it's respective location.

Mac: /Library/minecraft
Windows: Press Windows+R, type "%appdata%/.minecraft" and press enter.

But make sure you back the folder up!

Many people have used this technique for similar problems without: eg. Internet connection, so the launcher could not re-download the folder. This is also the folder were world saves and texture-packs are stored so again, back it up first.

if that does not help you need to wait for new vidcard drivers that might solve the problem.

  • sigh Please, fix your grammar. (I completely understand if your not a native English speaker though) – user92092 Nov 25 '14 at 10:48
  • i am a dutch italian – codermaster Nov 25 '14 at 11:32
  • Ok then. I understand. Your very good none the less though. – user92092 Nov 25 '14 at 20:26
1

If you are using a NVIDIA graphic card, this may be caused by threaded optimization. To disable it, open the nvidia control panel (in the windows control panel), get in the 3D settings and set the threaded optimization parameter to disabled.

1

It has happened to me before. To fix it I reset my render distance to the lowest and played for a bit. Then I turned it back up. Try pressing F3+A to reload all your chunks if all else fails.

1

I had the same problem, but on Multiplayer with Optifine - I was even going to ask a question until I figured out that if the Render Distance is 10 or over, some areas of the world glitch: Problem: Render Distance 10 and above Which I fixed by changing the Render Distance to 9: enter image description here Hope this helps, Zoweb

  • Hi Zoweb, the problem wasn't some graphical glitch but a legit flicker. It would work normally and then white flashes would appear in a flickering manor. – Baked Potato Mar 31 '16 at 1:34
1

Try this simple solution before you try reinstalling/changing drivers/etc.

Instead of running the Minecraft window full screen, resize the window to be just a little less than full screen. This fixed the problem for me running Minecraft on Ubuntu.

1

I had a similar problem. Go to options - video settings and turn Vsync off. I can't say if it will work for you but it did work for me, at least for now.

1

heres how to fix.

  1. turn down in-game settings
  2. open NVidia control panel
  3. select "adjust image settings with preview"
  4. select "use my preference emphasizing"
  5. adjust to "balanced"
  6. select "configure surround PhysX" on the left
  7. change processor to nvidia
1

I was running on integrated graphics. Changing to my 1050ti fixed it.

I had to go to Nvidia control panel, Manage 3D Settings, then change Auto-Select to Dedicated GPU.

0

Install the latest Java release. If you already have it, uninstall and reinstall it.

If the problem still occurs, Try to get the Java 7 update 6X or 7X version instead of the brand new Java 8 update 25.

  • this is probbebly a preforamce issue rather than a java issue – codermaster Nov 26 '14 at 6:04
0

it works for me look what to do

  1. go on lowest chunk render mean to 2
  2. play 5 minutes
  3. put it back to the number that was set before but DONT start the game only stay in menu
  4. close the game
  5. an java error will appear
  6. press close program
  7. open the game and it will not flick again
0

Alright so I had the same problem for the longest time. I finally found that if you RIGHT CLICK the minecraft icon and click the 'run with processor' drop down menu. Click the non-default processor (mines High-performance NVIDIA processor) This has stopped my screen glitching, but keep in mind that you need to do this EVERYTIME you start up minecraft.

  • Do you think there is a way to set this as default? – Baked Potato Jul 27 '15 at 23:40
0

After an incredibly long amount of time, this problem has finally been resolved. If I ran Minecraft through steam the flickers stopped. Why there were flickers and what caused this is still unknown, perhaps a bug in the programming.

0

The following works for me:

Enable options > Video Settings > USE VBOs

When I play without the GPU I have no problems, but when I plug in my R7260x I get this issue. For some reason, the bug happens only when I switch between the worlds. Below are some prints of the bug and my video settings. As you can see, I could not see anything:

Obs

My problem was not JAVA

0

So I realize this post is SUPER old by now, but since I stumbled upon this problem recently, I thought I'd touch base on how I fixed it. Firstly, I use MultiMC, and this still solved the issue, but I tried it on both MultiMc and the standard minecraft launcher.

Right click on either MultiMC or the standard MC launcher, click properties, click advanced and the check the box that reads "Always run as administrator" I havn't any clue how that solved it, but it fixed both my standard MC and all instances in MultiMC I currently had created. My specific graphic issue was when opening my inventory, my character would glitch out across the screen, and while roaming about item's sprites would just stretch out across the screen. This saves you the trouble of CONSTANTLY having to right click and "run as admin" so. There ya go!

0

Try setting chunk loading to default, Solved it for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.