I am quite new to dwarf fortress and trying to create an underground farm. I know that I need to muddy the ground so I havd created thd chanel above the farm and placed a pond activity zone over it. Shortly after I get a notice that filling the pond has been cancelled because there is no water source.

So I find the closest water source, a murky pond that seems to be 1 layer lower than the land around it. I dig a small channel section at the edge to access the water and set a water source activity zone. I then recreate the pond but get the same message that there is no water source.

What am I doing wrong here? Would someone mind walking me through creating a water source? Thanks

  • Is the murky pool salty? Failing that, perhaps you'd like to post your safe to the dwarf fortress file repository, so we can better debug your specific problem. Mar 24, 2011 at 5:50
  • No, I don't think that it is salty. Not sure what file repository you are talking about, but here is a link to the save file. filedropper.com/region1
    – tgrosinger
    Mar 24, 2011 at 16:02
  • for future record: dffd.wimbli.com Mar 24, 2011 at 17:46

3 Answers 3


I have not tried the fill pond strategy to make a farm, but rather the "planned flood" technique.

In 2d...

+---!---+             RRRR
|fffffff|             RRRR
|fffffff| +----+______RRRR
|fffffff| +----+      RRRR
+-------+             RRRR


  • R is a river (with 1+ layers of water above it, for pressure)
  • w is water storage, f is farm (7 f to 1 w)
  • C is a channel from 1 square above
  • X is a wall to dig out
  • ? is a door/floodgate hooked to a switch somewhere.
  • ! is a door for mud/water containment

To make the water storage:

  1. dig left C, tunnel, and storage room
  2. build door/floodgate at ?, and connect it to a switch
  3. make sure ? is OPEN
  4. Channel out right C
  5. When room is 7 deep, flip switch

Now, the storage room is filled with 7 * w units of water, one unit per bit of farm!

To make your farm muddy:

  1. Channel at X
  2. Run out of door
  3. Lock door until room is full of mud (and possibly fish)
  • The pond method isn't really working even on a new map where I can get water so I think I am going to give this a try. Thanks!
    – tgrosinger
    Mar 25, 2011 at 3:40
  • Haha flooded an entire floor attempting this... How do you dig the channel 'C' next to the river? I dug everything out first except next to river and 'X', then placed flood gate, then had to dig around to get to the river and dig it out. That caused the flood
    – tgrosinger
    Mar 25, 2011 at 4:26
  • You have to be careful with that. And the order I gave instructions in was so that if something went wrong, it would hopefully just flood the water reservoir. Remember: water can move diagonally. and the Cs are ment to be dug from above, to open the sealed tunnel and open reservoir to the river for filling. Mar 25, 2011 at 17:08
  • I'd suggest putting a floodgate at both X and ? rather than tunneling X out whilst the room is full. That way you can have the door locked and flood the farm room remotely. Much safer.
    – aslum
    Mar 26, 2011 at 6:40

It sounds like you're doing everything right on the pond end, since they actually tried to fill it.

I'm not sure what's wrong since your dwarves should just grab it from any available non-salt body of water, and you don't even have to set an activity zone over it. If they aren't dehydrating and living off booze, then I don't see why it wouldn't work.

If you aren't sure that it's accessible, or if it's saline, then you can just build a well over it to be sure. (It'll make your dwarves happier too.) You can build wells on any open space over water, and they'll automatically purify it. Be warned that wells will deconstruct if the water that it's over freezes, so be sure the gather the parts before it thaws again.


With a floodgate, attach a lever first and open it, then dig out the last bit of tunnel and get a dwarf to shut the gate behind your mirev when he is washed out.

  • Could you add more detail to your answer?
    – fredley
    Feb 6, 2014 at 13:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .