I got a skin, but it doesn't fully work.

Now I have my head, and nothing else. My body is just black; nothing is there. The skin seems to be only affecting my head and the bottom of my feet.

I used the newest version of the MinersNeedCoolShoes skin editor. Here's a screenshot:

How can I fix my skin?

  • 1
    Did you make sure that you have turned on second layers in Skin Customization Options? The file you have uploaded is missing first layer. It may be because you're in 1.7 but not sure.
    – Q20
    Oct 25, 2014 at 21:54

1 Answer 1


As @QbsidianH20 said, your skin is on the wrong layer.
The only way anybody's going to see your skin is if you turn on your secondary layers in the settings menu. If you're playing 1.7 or before - Tough luck as only that bottom black layer is going to show.

Consider shifting your body up 16 pixels. Also, your other arm seem to be missing too.
To fix that, simply copy your current arm texture and flip the textures (as needed).
Use this template if you do not know where to position textures for body parts.

Note: By 'black', I meant a transparent pixel (a pixel that has no color on it).

  • Aha... Thank you so much, the skins works fine now, I appreciate the help very much.
    – Mangka
    Oct 26, 2014 at 1:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .