5

As you can see in my screenshots, my alloy trucks tasked with delivering material to the arcology build site never return. It's been like this for days, with all of the them in the same spot, not moving at all. Bad thing is, since my shipment vehicles are stuck there, they can't deliver anything, meaning my entire trade system (which is the focus of my city) is at a standstill with only a few working vehicles. It's really hurting my budget (notice the ~$14.8k/hr deficit)

I've tried deleting vehicle garages at my trade depots and rebuilding them, but this doesn't seem to fix the problem. I have also tried logging off then back in with no avail.

Vehicles dropping off supplies to the great works never return

1

It's just a SimCity bug. I fixed it by deactivating all the construction contribution flows (Metal, Alloy, and TV 'power' buttons), then deactivating all of the trade depots. After leaving all these items deactivated for 4-5 hours of in-game time, I logged out then back into SimCity. Activate the depots and the vehicles should be fixed (if not, give it some more time).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.