2

I have successfully installed MineOS (Minecraft Server Admin Tools). I have it set up so that it automatically launches when I restart the server. I go to my.ip:8080 and the web interface is up and running. But I don't know the username and password to log in.

I tried 'admin' / 'minecraft2010' as well as 'tc' / 'minecraft2010' for login credentials, as suggested on a forum, with no result.

How do I change the password?

This page says as root I should use:

cd /root/runonce
./webui

But the /runounce/ folder does not exist. That script is apparently for Haiwatha servers.

I have MineOS installed on a Ubuntu 14.04 server, on AWS EC2.

MineOs Login

  • I tried using quadruple spaces before code snipets and it didn't work. I ended up using backwards apostrophes but the formatting does not look great. Would anyone be able to edit my post, as well as letting me know what I am doing wrong? Thanks. – Matt Lemmon Oct 27 '14 at 23:33
  • So have you changed the password or is this a fresh install? – user271360 Oct 28 '14 at 0:01
  • It's a fresh install. – Matt Lemmon Oct 28 '14 at 16:49
  • Ok, could you check if @hexparrot's anwser helped you, if not could you post your log from /var/log/mineos.log into a comment below, (if it is too long just upload it to pastebin. Also remember to delete or replace any personal info, IP's, etc - you do not want us to see! – user271360 Oct 28 '14 at 20:13
  • Thanks very helpful. I am on my way, but I will be posting separately about difficulties with importing a world to MineOS. – Matt Lemmon Oct 28 '14 at 20:16
2

MineOS uses the existing credentials of your server (shadow passwords); In practical terms, this means any of the user/password combinations you can use to log into the command line (or SFTP) will be the same combination you use in MineOS.

The usernames you listed, "admin" or "tc"--since they don't exist on your Ubuntu server--will not permit login into the MineOS webui.

The other username listed "mc" is a common login for users who installed via the MineOS Turnkey ISO, rather than the installation process you did atop an existing Ubuntu installation. In this case, the loginname was created by the install process and prompted the user to set the password.

In short, create a new user using normal Ubuntu user-creation steps and you should be set.

  • Thanks that worked. I will post a separate question about Importing existing worlds. I will post a link here once the question is created. – Matt Lemmon Oct 28 '14 at 20:15
  • @MattLemmon Consider posting your question in the MineOS forums instead--discourse.codeemo.com; You'll be able to get specialized help from the MineOS community and developer more directly. – hexparrot Oct 28 '14 at 20:24
  • Sounds good. Here is the new question. – Matt Lemmon Oct 28 '14 at 20:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.