You will need to use the appropriate name of the block/item dependant on your Minecraft Version.
Minecraft 1.11 and Later
Now, I'm going to assume that you are using the newest version yet, Minecraft 1.11.2 .
If so, perfect.
You'll want to modify your command so it looks a bit like this:
The Radius-Parameter isn't necessary, but useful for when you are in an area hosting many Command-Block-Minecarts (As you'll be able to detect and maybe get rid of the ones you don't need with the Radius-Parameter).
... bit, is to specify that It Is Indeed a Command-Block-Minecart; the new ID was introduced in the early 1.11 Release (Snapshot 16w32a), because... well, Mojang haven't specified a reason yet, but it's assumable that it's to prevent typos.
Link to the Gamepedia-Wiki page on it: Command Block Minecarts
(Note: that the capitalisation of 'Command' is in place by standard. If it does not work for you, change the first letter to a lowercase 'c'. That goes for all items/blocks referenced in commands.)
Minecraft 1.10 and Versions Before
If your version is, as said above, 1.10 or before, you'll have to use the original in-place name for it:
... and in a /testfor command:
Again, the Radius-Parameter isn't necessary, I regularly insert them for clarity and by-tradition.
(Second Note: The ' /testfor '-Command is only present in Minecraft Versions 1.5 (Snapshot 13w03a) and Higher!)
In short, different names are used to improve readability, portability and general mark-up.
' commandblock_minecart ' for Minecraft 1.11 and Later,
' MinecartCommandBlock ' for Minecraft 1.5 to 1.10 .
I hope my answer has helped solve your conundrum.