14

I have an nvidia gpu and as such will not be launching Beyond Earth with the mantle option. Is there a way to bypass the start up option of launching in normal mode or mantle mode, and just always default to normal?

  • So, I have a nVidia GPU as well. I was asked if I wanted to use Mantle the first time I started up the game. Since then, I've never been asked again. – Ellesedil Nov 4 '14 at 21:19
5
+50

Instead of clicking the blue "Play" button, right click "Beyond Earth" in the library list, then choose "Play game..."
For whatever reason, this option skips the Mantle question and directly launches the game.
Of course, we are talking about a PC game; your experience may vary.

  • Ah-ha, so there is a consistent way that steam can do it. This means there is a consistent way for us! Great find. – Kexlox Nov 5 '14 at 13:08
4

Thanks to @Dirty Beach finding a way to do it from Steam, this gave me a process to hook into and watch running to see how Steam does it.

The short answer is running the CivilizationBE_DX11.exe with a -DX11 command line parameter. This allows you to start straight into the game without a pop up, and allows cloud saves to be enabled!

Of course, if you just make a shortcut straight to the exe and throw command line parameters on it, Steam asks if you are sure you want to use them. This just gives us a different pop-up. However, this question shows us how to deal with that.

TL:DR; Create a shortcut to your steam.exe. Modify the target to be:

C:\PATH\TO\STEAM\Steam.exe -applaunch 65980 -nosplash -DX11

Modify Path to steam as appropriate

  • Just to be clear: you're creating a shortcut to Steam, (not to Beyond Earth) and in that shortcut, telling Steam to immediately launch Beyond Earth with the provided options. So... It's still launching through Steam, just without having to bring up the Steam client window? – Sean Beach Nov 5 '14 at 16:23
  • Correct. I do this when Steam is running, no need to shut it down first or anything. Theoretically this should be the same as adding the -DX11 parameter through the launch options in Steam, but that doesn't seem to do anything. – Kexlox Nov 5 '14 at 19:38
2

Theoretically, you should be able to just launch the game through the game's executable directly (e.g. using a shortcut).

However, at least in my case this results in the following error message:

The Steam servers are too busy to handle your request for Sid Meier's Civilization: Beyond Earth. Error Code (41)

http://support.steampowered.com

You can still give it a try though. If it doesn't work, just stop trying and start the game as usual:

  • Go to your game's installation directory. This will typically be <steam library root>\SteamApps\Common\Sid Meier's Civilization Beyond Earth.
  • Find the application CivilizationBE_DX11.exe and create a shortcut to it (e.g. by dragging it directly to your task bar).

As an alternative, right click the Steam icon on the task bar and click the game's link under Recent. This should launch the game directly.

  • I always do that last option. Doesn't help with this choice. Always get the pop up. – Frank Oct 31 '14 at 20:16
  • Odd, at least that one works for me. – Mario Oct 31 '14 at 20:21
  • Yeah, I launch from the recent list as well, and it gives me the pop up. This last time, it was hidden under the steam library window, and I waited longer than I'd like to admin for the game to start. Hence the question :) – Kexlox Oct 31 '14 at 20:37
  • I tested the first method. If you're getting error 41, then turn off Steam Cloud for the game. Otherwise I can confirm that linking directly to the game skipped the Mantle dialog for me. – Thebluefish Oct 31 '14 at 21:08
  • So, just tried this out, didn't work for me. However, if I exit steam completely, then use the shortcut, it starts directly into the game. That seems like a bit much though. – Kexlox Nov 4 '14 at 2:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.