3

I have run a Minecraft server for over a year. I had a netgear router on Comcast network. We recently got a 'new' all-in modem/router, one that needed to be configured. http://canyouseeme.com says that the external port is being forwarded at 25565, but I can only access the server on my internal network. This is really bugging me, and I am out of ideas. Here are the pictures I have of my trials.

Note: I assigned my server computer a static IP of 10.0.0.28 so there is no problem with the internal IP of the server computer not matching the IP address that is in the port forward settings.

In response to a below comment: I used to connect to my server using the external address even though I was on the local network. My computer is on same network as my server. I can log on with my direct connection but not with the external IP. This leads me to think that there is a problem. enter image description here

enter image description here

enter image description here

enter image description here

  • In the future, please copy the server.properties file into a code block. – user28379 Nov 5 '14 at 22:25
  • 5
    Are you trying to connect to the server from the web address while still at your home? Things work a little differently when you try to access local ips through a non-local host... it's a little complicated. Are you at home while accessing the host name? – Luke Nov 5 '14 at 23:16
  • 1
    @Luke yes he is, you can see the local IP as another server entry in his screenshot. – Thraka Nov 6 '14 at 3:24
  • You generally cannot connect to the external IP address when coming from inside your network since you reach the router "from the wrong side". The port forwarding only works (generally) when you're coming from the outside. The old router must've forwarded the ports also from the inside, which in my experience is generally not done. Since you've posted your IP address in the post, I took the liberty of trying a simple telnet to the external IP address, port 25565, and I was able to connect, so the port is definitely open. – Lasse V. Karlsen Nov 6 '14 at 9:00
  • Having said that, do you need to connect to it using the external IP? Won't it work if you just connect to the local IP instead? – Lasse V. Karlsen Nov 6 '14 at 9:01
1

If you were trying to connect to your server within your own network, use localhost instead of the public IP address. This would be assuming that you are running the server on the same computer that you are using to play Minecraft. If you are trying to connect to your server from a different computer within the network, just use the internal IP of your server host computer, in your case, 10.0.0.28, and you can add :25565 to the end of it just for good measure. Hope this helped!

0

Armed with the above comments I feel I can now answer your question fairly definitively.

Because the magic of internet technology is different than you expected, you'll have to connect to your minecraft server differently when you're at home vs not.

To achieve some semblance of what you were looking for you have a few options:

  1. You can simply "Add Host" for the non-local hostname and a 2nd for the local ip address, and connect to the one that will work based on whether you're at home or not (this one is the easiest)
  2. You can edit your hosts file. You would want to specify the non-local hostname and re-locate it for your computer to the local ip address. IMPORTANT NOTE: This will make your computer never connect to that hostname when you're not at home.
  3. You can edit the outbound rules for your router to redirect traffic from your computer to your server's hostname to the specific internal ip that your server has. Please note that this should be done with extreme caution and care because if you do it wrong you could mix up everything your router is doing and make yourself quite confused. Please note, this is the "best" solution, but is probably the hardest to pull off correctly.

Best of luck! Also - you probably want to edit your question and redact your personal IP address, as well as the location/hostname of your server.

0

I FOUND THE AWNSER! something wrong has happened to your broadband router... Just Go To CMD And type ipconfig your ipv4 address may have changed! change the inbound rule to your new ipv4 address aka this imageI Have Kept My IPV4 Address Secret

-1

Some routers and/or ISPs have a quirk where you cannot access the router on the WAN from inside the router. Try having a friend log in.

  • 5
    Not really a quirk, but more a common security feature that exists for a good reason. It's called local-loop back; and was already mentioned some time ago by another user -- so this answer doesn't really add to the knowledge here. – TZHX Jul 17 '15 at 18:24

Not the answer you're looking for? Browse other questions tagged or ask your own question.