0

When I launch any Steam games like Cs:Go or TF2, My engine always says that the overlay is not on before launching, causing me to always open up my System preferences and I have to put in the password and double click on the check box next to steam before I play. Is there any way to set steam so that I do not have to do this before each game?

1

"Steam updating should not cause permissions to need to be re-enabled. Also, I have noticed this occurs more often than Steam updates. It is more likely an issue with Yosemite that has not been patched in Steam yet. "

(All credit should go to tubedogg.)

4
  • Yea That's what I think it is.
    – Neffer_23
    Nov 11 '14 at 19:53
  • @Neffer_23 Cool, hope it helped you.
    – user271360
    Nov 11 '14 at 20:45
  • so there is really no way to fix it. I just have to wait until steam fixes it.
    – Neffer_23
    Nov 12 '14 at 1:58
  • Yes, but that should happen promptly because they would be losing money and clients if they do not fix it.
    – user271360
    Nov 12 '14 at 4:19
0

It happens after a steam update, I believe.

You may be enrolled in Steam beta updates, which would lead to permissions being reenabled everytime Steam or a Steam game starts.

2
  • 1
    Steam updating should not cause permissions to need to be re-enabled. Also, I have noticed this occurs more often than Steam updates. It is more likely an issue with Yosemite that has not been patched in Steam yet.
    – tubedogg
    Nov 7 '14 at 7:21
  • okay makes sense.
    – Neffer_23
    Nov 7 '14 at 19:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.