5

I installed Age of Empires I on Windows 7 SP1 x64 Ultimate. After the installation whenever I tried to run the game (Empires.exe) I get the following error right at the beginning:

enter image description here

Could not initialize graphics system. Make sure that your video card and driver are compatible with DirectDraw.

I tried to change the compatibility mode and run as administrator but it didn't help:

enter image description here

I followed the instructions printed on DirectDraw or Direct3D option is unavailable but it didn't work (and they went written for Windows XP, not Windows 7).

In dxdiag I checked that all my displays have DirectDraw enabled:

enter image description here

enter image description here

I tried to change the monitor's resolution to 800x600 (which is the default resolution of Age of Empires I):

enter image description here

What else can I try to solve the issue (without having to run Age of Empires 1 on a different OS, and without having to buy anything else as I have already bought the CD over 15 years ago)?

Note that Age of Empires I does work fine with Windows 7 SP1 in a virtual machine, so I guess it might be due to some conflict with my graphic card's drivers (NVIDIA GeForce GTX660M).

  • Is this installed from the Original disks, or from the Steam re-release? – tombull89 Nov 8 '14 at 18:02
  • 1
    From the CD I bought ~15 years ago. – Franck Dernoncourt Nov 8 '14 at 18:03
  • 1
    According to the dxdiag screenshot you're using Intel HD Graphics, not NVIDIA GeForce graphics as you say later in your post. – user86571 Nov 8 '14 at 23:00
  • @RossRidge Thanks, good catch, I'll investigate this. – Franck Dernoncourt Nov 10 '14 at 16:04
  • @FranckDernoncourt Did you find a solution to this issue? How did you fix it? – galacticninja Dec 8 '14 at 6:56
2

I would say it's your drivers. I had the same problem as you. I had to reload Windows and didn't update the video drivers to the latest and the game is working. Sims3 is also working for me now.

  • Thanks. What do you mean by reloading Windows? The issue seems to be caused by the driver indeed. – Franck Dernoncourt Dec 8 '14 at 4:39
  • 2
    'Reloading' Windows (re-installing?) seems a tad on the extreme side for older video drivers. Typically you can find older drivers on the manufacturer's (AMD/NVIDIA) website. – Trent Hawkins Dec 8 '14 at 8:02
1

Right click on game shortcut-->properties-->compatibility, and tick the checkbox saying " run in 640X480 resolution ". On windows 10, there's an additional option: a checkbox saying "use reduced color mode" tick that too and select 16-bit. That worked on my PC. I'm using a 64-bit i3-5th Gen, with intel HD graphics 5500.

0

The issue is a graphics card problem where your card is too powerful for the game.

Try any/all of the following to fix the problem:

  • Uninstall the game completely then reinstall (only worth trying if the game ran at least once before you experienced the problem)

  • Update your graphics card drivers

  • Downgrade your graphics card drivers

  • Disable your graphics card within Device Manager then restart Windows (remember to re-enable after you have finished playing)

-1

Run Win95 in Dosbox. Then you just run the software + you can play any other oldie instead of messing with hardware settings and restoring them after playing.

  • 1
    You've now answered two questions with basically, "Run DosBox." While that sort of answers the question, it doesn't do a very good job of it. Why does Dosbox fix this? Why is this better than trying compatibility mode? – Frank Jun 7 '16 at 22:03
  • If simple compatibility mode would work, we wouldn't be having this discussion. Many old games won't work even in compatibility mode because they are 16 bit, need specific graphics or similar. DOSBox is one solution I know for running old Win in your current Win. Another solution is to use virtual machine and install older Win there. Third one is to have old machine with older Win :) DOSBox is not necessarily the only solution for this. I find it better then downgrading graphic card drivers. That's just matter of prefernace. So why the downvote? – Marko Stanojevic Jun 7 '16 at 22:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.