1

I thought I would run this here, as the conventional solutions (disable Steam overlay, run without Steam, etcetera) have been ineffective, or in one case seemed to make it even worse.

Starbound is still in beta, but I really enjoy playing it. I run Cinnamon on Ubuntu 14.04 on a 64-bit linux kernel. I have 3GB of RAM, a 3 GHz processor, and a GeForce GT610 graphics card with 2GB VRAM and external cooling (core temperature never rises above 50°C). All the same, the whole program will bog down to 4-10 FPS, pretty frequently.

The nature of the slowdowns makes me think that it might be an inefficiency in buffering data to the graphics card, or something in the drawing algorithm; but I can't be sure. I have zero interest in running it on Windows. Has anyone resolved this issue for a similar platform, and would you explain how?

4

Know what, I think I just found my solution, via saintcyre at http://www.reddit.com/r/starbound/comments/1v81mb/slow_or_laggy_starbound_fix_i_got_120fps/ .

The fix, summarily, involves changing starbound.config
(located at ~/.steam/steam/SteamApps/Common/Starbound/).
I went ahead and altered the file, with the following modifications:

  • "maxFrameSkip" to "1"
  • "renderPreSleepRemainder" to "1"
  • "renderSleep" to "false"
  • "vsync" to "false"
  • "waitForUpdate" to "false"

As a result, it seems to have done the job. The only slowdowns I now get are rather moderate and they seem to primarily be when the game is loading a planet. It's lightning fast now, so bravo!

I was a little curious about how applicable all of these options would be, as he's running it on Windows 7, not Ubuntu 14.04. Some of them may have been unnecessary on my system. I also strongly recommend backing up starbound.config as starbound.config.bak before you make any changes, just for the sake of having a fallback plan. Messing with .config files can also seriously break a program.

Additonal: I've also discovered that a current bug on Cinnamon causes sudden and inexplicable brief freezes in video rendering. I'm using version 2.2, and it has yet to be corrected. Aside from affecting video, it also shows up in SDL apps, like Starbound. If this is the case, I suggest switching to a different desktop environment until the bug is fixed. (Maté works great.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.