2

I am trying to install Minecraft for the first time. I have tried to uninstall Java and reinstall. I have tried shutting off the firewalls. I do not know what else to try. Anyone have any ideas? I am getting the following error...

[20:04:06] [Client thread/INFO]: Setting user: dragondecimator
[20:04:06] [Client thread/INFO]: (Session ID is token:f5c4b35f76f643488e5207346aabfbf5:31e215dcad9647e6afbef45d1687ae61)
[20:04:09] [Client thread/INFO]: LWJGL Version: 2.9.1
[20:04:09] [Client thread/INFO]: Reloading ResourceManager: Default
[20:04:10] [Sound Library Loader/INFO]: Starting up SoundSystem...
[20:04:10] [Client thread/WARN]: File minecraft:sounds/mob/ghast/fireball.ogg does not exist, cannot add it to event minecraft:item.fireCharge.use
[20:04:10] [Thread-6/INFO]: Initializing LWJGL OpenAL
[20:04:10] [Thread-6/INFO]: (The LWJGL binding of OpenAL.  For more information, see http://www.lwjgl.org)
[20:04:10] [Thread-6/INFO]: OpenAL initialized.
[20:04:11] [Sound Library Loader/INFO]: Sound engine started
[20:04:13] [Client thread/INFO]: Created: 512x512 textures-atlas
#
# A fatal error has been detected by the Java Runtime Environment:
#
#  EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x27583e88, pid=4092, tid=3656
#
# JRE version: Java(TM) SE Runtime Environment (8.0_25-b18) (build 1.8.0_25-b18)
# Java VM: Java HotSpot(TM) Client VM (25.25-b02 mixed mode windows-x86 )
# Problematic frame:
# C  [ig4dev32.dll+0x3e88]
#
# Failed to write core dump. Minidumps are not enabled by default on client versions of Windows
#
# An error report file with more information is saved as:
# C:\Users\Andrea\AppData\Roaming\.minecraft\hs_err_pid4092.log
#
# If you would like to submit a bug report, please visit:
#   http://bugreport.sun.com/bugreport/crash.jsp
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#
AL lib: (EE) alc_cleanup: 1 device not closed
Java HotSpot(TM) Client VM warning: Using incremental CMS is deprecated and will likely be removed in a future release

marked as duplicate by Robotnik Sep 26 '16 at 7:06

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • What operating system are you using? Is it Windows? – Studoku Nov 11 '14 at 17:33
  • 1
    An access violation in ig4dev32.dll probably means there is an issue with Intel integrated graphics drivers. You may want to look at an issue with a similar cause. – JvR Jan 25 '15 at 11:39
3

There is nothing wrong with minecraft, but with Java. You are using Java 8 which is not really stable, so refrain from using it.

To solve this issue you should uninstall Java 8 and install the latest update of Java 7.

  • It is also possible to use a specific version of java by running the executable by specific path reference instead of using the "installed" version. It becomes a lot more complicated to get it open (you have to use the command prompt), but you can do it. Look for the place you have the executable for java 7 and run it with that full path. – Luke Nov 11 '14 at 18:52
  • @Luke - You can set the java path through the profile editor. No command prompt needed. – aytimothy Jan 19 '15 at 11:12
  • @aytimothy If minecraft is the only thing you need Java for, then modifying the java path works perfectly. If java 8 is needed for anything else (like eclipse) you would be better served running it specifically. One can bypass the command prompt in many ways, though, so my comment isn't perfectly accurate that you need to use it. It seemed to me the simplest way to describe it. There's always more options. – Luke Jan 21 '15 at 17:45
  • @Luke, do you even know what you're saying? | By the way, setting the java path through the profile editor only affects that Minecraft profile. Not any other program. Not even your other profiles (if you have any). – aytimothy Jan 21 '15 at 18:01
  • @aytimothy I misunderstood what you were saying. I thought you were talking about the java path variable on the system, not the path in the minecraft profile. My mistake. Yes, I know what I'm saying but that does not mean I knew what you were saying. – Luke Jan 21 '15 at 18:18
3

A EXCEPTION_ACCESS_VIOLATION (0xc0000005) means that Java is unable to read/write to the tempoary memory (RAM).

The reason you received that error is because:

Your computer tries to load assets (ie. textures) into the memory, but loaded it into a portion of the RAM that was not allocated to javaw.exe (the Java runtime that runs Minecraft).

There are many reasons this could be caused, try the following to fix:

  • Reinstalling any graphics drivers, as broken drivers may have caused the misallocation and loading of memory.
  • Make sure javaw.exe and java.exe is running as an administrator, as sometimes it tries to load things into memory defined to it (by the software), even though it was not allocated (by the system).
  • Downgrade from Java 8 to Java 7 as it is not stable... Yet.
  • I like this answer because minecraft 1.8 should be working fine with java 8. However, you shouldn't need to run java as administrator. More information on why the minecraft.jar file is unreadable would be nice from the OP. @Drae Could you pasebin your file at C:\Users\Andrea\AppData\Roaming\.minecraft\hs_err_pid4092.log – Luke Jan 21 '15 at 17:49
  • @Luke, it can't read it because it does not have permission to. (That's why you run Java as an administrator to allow it to read) | Also, did you click the link? – aytimothy Jan 21 '15 at 17:54
  • I did now (I hadn't before). You've done your homework on this issue, so your answer is a good one. The OP didn't say what OS they are running, so it might not be windows 7 or vista. In general it is good advice not to disable security features like the UAC (which is bypassed by running as administrator), but if Sun is recommending that (which they aren't if you read the warnings below their solution) then it should work. All that being said, the OP should try and probably accept your answer. Buyer beware. – Luke Jan 21 '15 at 18:25
  • @Luke, since when Mac (or Lunix) has a C Drive? | They're usually root\[insert any file path here]. | Also, Oracle Inc. is the company behind Java. – aytimothy Jan 21 '15 at 18:33
  • I'm not flaming you. I was referring to windows 8. Again, your answer is good. I'm just trying to add more information. No worries. About the ownership of java, my mistake. I keep forgetting that Sun sold it. You're very good at finding my mistakes. – Luke Jan 21 '15 at 20:08

Not the answer you're looking for? Browse other questions tagged or ask your own question.