1

All along, I've been playing several Clash of Clans accounts using different Game Center accounts on one device, and the switching worked just fine, with the switch village option pop-up always available.
But just yesterday, I logged into a friend's Game Center and COC accounts and when I tried to log back into my own accounts today, the switch village option isn't available and my Game Center is now stuck with my friend's COC account!

Is there a way to solve this problem? I've tried to delete the app, logged out of my Game Center account, restart my device then re-login into my Game Center account and re-install COC app, but it doesn't work at all! I tried to reformat my device too but it didn't work as well! Please help me! Thank you very much!

  • It very well seems like your friend's village has become bound to your Game Center account.. With that: There's nothing you can do. – aytimothy Nov 15 '14 at 6:53
  • Delete both of accounts. Legally sharing accounts is not allowed. Your accounts can get permanent ban because of sharing accounts. – Fennekin Sep 29 '17 at 16:46
1

Make sure your friend is not still logged into your Gamecenter account. There might be a conflict by having two devices connected to one Gamecenter account. If problems continue, then consult either Apple support or Supercell support. Take note that Supercell customer service is not the best.

protected by Community Nov 15 '14 at 8:22

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.