1

I can't access the NotEnoughItems tab and I've tried switching between survival and creative mode.

I can see the option button down to the left but I can't see the items tab to the right. What should I do?

Edit: I found the solution on my own. I had apparently changed the GUI scale option to auto Which is too big, you want to have it on large or normal.

You can find the GUI scale option in Options>Video Settings.

  • Is it installed correctly? No crashes etc? – user271360 Nov 16 '14 at 4:46
  • What tab are you actually looking for? (The one on the right third of the screen? Or the buttons on the top left? Or the tab that goes straight on top of the inventory window, similar to creative ones?) – aytimothy Nov 16 '14 at 5:10
  • I am looking for all tabs that u get with nei the only one I can see is the options tab I want to be able to search and look up recipes in the items tab. I've downloaded this mod in a pack: agrarian skies but the mod worked for a wile and then all of the sudden it stopped working. – Erik Lindman Nov 16 '14 at 11:44
  • And I don't know what I've done – Erik Lindman Nov 16 '14 at 11:45
3

I had the same problem. You have to click in the normal setting for Minecraft: OPTIONS, VIDEO SETTINGS and set GUI scale on large. If that does not work I do not knowenter image description here

1

In the inventory screen with the NEI mod installed, you can access the item tab only if you're in:

  • The inventory tab in the Creative Menu
  • In Creative+ mode
  • In Survival/Adventure

Alternatively, if it's not appearing at all: Try pressing O in the inventory screen, and/or enable cheatmode.


There is a bug where the items tab (on the far right) displays nothing at all. You should also notice that the page number is higher than the maximum page number. (ie. Page 5 / 2)
Simply go back into the range (in this case, Page 1 or 2) and the items should clear again.

Another thing is that you may have searched for something and then forgotten to clear the search filter. (ie. You searched for 'asdfasdfas' and nothing came up, as no item contain 'asdfasdfas' in it.)

  • When I press o the only thing that happens is the options tab appearing and re appearing. Creative menu? Do u mean in options/inventory – Erik Lindman Nov 16 '14 at 11:29
  • Are you in the inventory tab in the Creative Menu? (Bottom-right-most tab sticking out of the inventory box that looks like a chest) – aytimothy Nov 16 '14 at 11:37
  • When I am there what am I supposed to do – Erik Lindman Nov 16 '14 at 14:29
  • ... Can you post a picture of what you see? (How? Use Gyazo or any screenshotting program) – aytimothy Nov 16 '14 at 23:10
  • I don't realy know how i wuld do that but i can discribe: when I for example go in to my inventory with E, I can see both my inventory screen and the options tab Down to the left but nothing else – Erik Lindman Nov 18 '14 at 14:30
0

In order to access the not enough items tab, you must change your gamemode to Creative+. If not, then the panel will not show up and you will only see normal vanilla Minecraft GUIs. To change to Creative+, you must either click the "Change gamemode" button on the top left corner of the panel.

You can also uninstall NotEnoughItems and install it again, if the above solution doesn't work.

  • I can't access the change gamemode tab at the top left corner. Only the options tab – Erik Lindman Nov 16 '14 at 11:24
  • I go to options/inventory then I have tried to both enable and disable nei I've tried to press creative, creative+ and the adventure button but no success. I've also tried to switch between cheat, recipe and utility mode but nothing seems to work – Erik Lindman Nov 16 '14 at 11:38
  • Try uninstalling and reinstalling it. Maybe some of the files are not right or some problems occurred. Which version of NEI are you currently using? – 54D Nov 16 '14 at 11:52
  • Version 1.6.1.9. – Erik Lindman Nov 16 '14 at 14:24
  • Hmmm... Then the only way will be reinstalling NEI. Remember to backup the mod file before you delete NEI and install it again. – 54D Nov 16 '14 at 15:10
0

As far as I know, NEI can not grant you items, change game mode and do all such cheaty stuff if you have cheats disabled when creating a world.

  • Ihave cheats enabled on my world but i saw somthing in the mods tab. in the Main menu yesterday i will tell u guys what where i come home. (it's a red text) – Erik Lindman Nov 18 '14 at 13:28
  • It ses "no installed plugins – Erik Lindman Nov 18 '14 at 15:27
0

You've found a bug. Go to single player, and load a world and it should work. Go back to Multiplayer, and it should still be working. Not sure why this is happening again.

Not the answer you're looking for? Browse other questions tagged or ask your own question.