5

I recently bought a 4k screen and wanted to play Borderlands 2 in my new screen's native resolution. For some reason every time I launch the game it resets my resolution to 2560x1440.

I've tried changing the resolution ingame and through the launcher, and even made the config file read-only, but to no avail.

How do I get Borderlands 2 to render in 4k?

8

I noticed setting the resolution to 4k ingame made the game look worse than when it rendered in 2560x1440, so I had a hunch the game was rendering in 4k and scaling the graphics back down to 2560x1440; typical scaling behavior on high DPI screens.

So what I did was force Windows to stop scaling the game. There are 2 ways to do this (works for any app, not just games).


Use compatibility mode to turn scaling off

This method is quickest and easiest to do.

  • Right click on the .exe or the shortcut to the .exe, and select Properties. Keep in mind that shortcuts created by Steam don't point to the .exe, so you'll need to find the actual .exe instead, for instance: C:\Program Files (x86)\Steam\SteamApps\common\Borderlands 2\Binaries\Win32\Borderlands2.exe.
  • Switch to the "Compatibility" tab and check "Disable display scaling on high DPI settings".

Add an exception to the registry

Simply copy the following code...

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers]
"C:\\Program Files (x86)\\Steam\\SteamApps\\common\\Borderlands 2\\Binaries\\Win32\\Borderlands2.exe"="HIGHDPIAWARE"

... into a regular text file and change the text file's extension from .txt to .reg, then double-click the file to execute it. You might need to accept and provide elevated privileges.

The advantage of the registry approach, is that you can keep the registry file around and execute it on any device where you might need it. Most useful when you buy or build a new PC and want a quick way to solve all your scaling-related issues on your new machine. Simply expand the registry file like this:

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers]
"[path to app 1]"="HIGHDPIAWARE"
"[path to app 2]"="HIGHDPIAWARE"
"[path to app 3]"="HIGHDPIAWARE"

and so on.

3

With the release of the official Borderlands 2 Ultra HD Texture Pack, you can just download the free DLC and change the resolution in-game.

The pack includes:

  • Remastered 4K environment textures, including geometry and skyboxes
  • Remastered 4K characters and vehicles
  • Remastered 4K weapon meshes and textures
  • Improved Anti-Aliasing implementation, including improved edge line implementation
    • This includes improved ink line definition and framing/outline around character models
  • Improved Screen Space Ambient Occlusion
    • An improved SSAO method for more realistic ambient lighting.
  • Higher Resolution Dynamic Shadows
    • Improved quality and smoothness of shadows, especially during movement

Note that this pack is not available on Mac or Linux, and co-op play with Mac or Linux users is not possible if this DLC is installed.

  • 1
    Heh good to see this DLC. I was planning a re-play of borderlands 2 in anticipation of borderlands 3. Thanks. – Lore Friendly Jun 14 '19 at 14:28
  • That's what I thought at first, but the 4k DLC doesn't actually introduce HighDPI support, which is the cause of this problem. I still had to turn scaling off to get the game to render in 4k. – Nolonar Jun 14 '19 at 21:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.