0

Okay so I recently lost my palladium drill and I had to make a gold pickaxe so I could mine, unfortunately the pickaxe does not work on any ore (I can't tell if the ore I tried mining with it was palladium or copper, it won't even mine crimson rock). I can mine dirt and rock just not ore. What is wrong here? Please help. To add on, I also tried mining with a lead pickaxe and still no luck.

2

The Gold Pickaxe can not mine Palladium Ore, since this is a Hardmode Ore. But the Gold Pickaxe should be able to mine Crimtane Ore.

If you are not able to mine any ore at all, your save file may be corrupt, and I suggest you create a new world, and try to do the same thing. If the same phenomenon reoccurs, you should try to re-install the game completely, as this is something that should not happen under normal circumstances.

  • Never mind about me not being able to mine any ore. It was palladium I tried to mine before because I just used my lead pickaxe on tin and it worked fine. Any suggestions on what I can use to mine my hardmode ore? – cat_ccl Nov 17 '14 at 17:34
  • @cat_ccl Here are all pickaxes in the game, and if you want to mine Palladium Ore, you should choose Molten Pickaxe or better. – Havatra Nov 17 '14 at 17:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.